EditControl update problem

EditControl update problem

Post by EE » Mon, 29 Nov 1999 04:00:00



Hi friends!

(CAVO 2.0b4)

1. A SLE or MLE (in DialogWin) has any text or not on it and is saved
OK to the DBF

2. Later when I re enter to the window and try to add or correct some
text into the already existing text the cursor doesn't move and no
character is added.

To be able to add some new text I have to paint with the mouse some
extra space. Even this solution does not work all the times.

I need the EditControl to be ready for text input as soon the window
is shown and the cursor is placed by the user on any place within the
text.
How can this be done?
Is there any special command or setting I'm missing?

TIA
Ernesto

Ernesto

 
 
 

EditControl update problem

Post by Geoff Schalle » Tue, 30 Nov 1999 04:00:00


Ernesto,

Common problem experienced by most of us from time to time. The best answer
(and this is not being sarcastic) is to upgrade to 2.5 where you have much
greater flexibility with cursor positioning and text control text selection.
Other than that, get some of the freeware in the Forum Library where a
number of people have written replacement SLE classes. If you study the
dispatches of these classes you will see how it is done.

Check out the VO Forum Libray.

Geoff


Quote:> Hi friends!

> (CAVO 2.0b4)

> 1. A SLE or MLE (in DialogWin) has any text or not on it and is saved
> OK to the DBF

> 2. Later when I re enter to the window and try to add or correct some
> text into the already existing text the cursor doesn't move and no
> character is added.

> To be able to add some new text I have to paint with the mouse some
> extra space. Even this solution does not work all the times.

> I need the EditControl to be ready for text input as soon the window
> is shown and the cursor is placed by the user on any place within the
> text.
> How can this be done?
> Is there any special command or setting I'm missing?

> TIA
> Ernesto

> Ernesto


 
 
 

1. Oracle 7.0 Update Problem..Row changed before update etc

I am having a problem with one of my datawindows.  When the datawindow
does it's update, I occasionally get the error "Row changed before update
etc..." from the server.  I have set the update characteristics according
to information found in InfoBase (Update Key and Modified cols...UPDATE
instead of delete-insert) but I still have this problem.  Does anyone know
of a procedure that will get a successful update 100% of the time?

thanks

Corwin Moczygemba


2. PPS ZEUS '040

3. UPDATE FROM problem, multiple updates of same row don't seem to work

4. Solaris 2.4 Kernel's IP PCB

5. not allowing to update my updates

6. NEC 500 #x and PAS 16

7. Messenger update ; not updating

8. replacing a file on all computers

9. MSN tried to update to 5.3 client update and then crashes

10. What is better UPDATE or DELETE/UPDATE (w/ Oracle 7)

11. Automatic update of table, does not update web site

12. Update Row Level Trigger: default value for update trigger

13. LIMIT 1 FOR UPDATE or FOR UPDATE LIMIT 1?