FATAL 1.6.24b (PC) Upgrade error, upgrade aborted!

FATAL 1.6.24b (PC) Upgrade error, upgrade aborted!

Post by Henk de Gro » Tue, 02 Feb 1993 23:03:46



Hello Netters,

I own PC-Minix version 1.5 from Prentice Hall and wanted to upgrade to
1.6.24 (beta).

Before I bought 1.5, I asked the net how to get the latest version of Minix.
The advice I got was buy 1.5 and upgrade from the net. To my dissapointment
this seems to be impossible!

I've got all the upgrade files for 1.6.24b but that's not enough. First of
all the upgrade kits on star.cs.vu.nl and plains.nodak.edu are both missing
syscall.ansi.sh and syscall.kr.sh. I reported this on the net with a
question where I can get them. No response. Although I have to use a clumsy
way to ftp I found them on the ftp-site in koeln (with the correct crc's).

The commands.sh file on on star.cs.vu.nl and plains.nodak.edu doesn't
contain the file whatis.sh, although it should. From what I read I understand
that it has been updated to fix some other problems (the date of the file
differs from the rest of the kit on star.cs.vu.nl), and the whatis.sh file
was lost. I got whatis.sh from the 1.6.23 upgrade on koeln, the crc matched.

Now that I've got everything I started to apply the patch. Using only a 10Mb
partition I did it part by part, starting with the commands, then the kernel,
the include files and finaly the library. I only whished I started with the
library, because that whould have saved me a lot of time.

The library is very incomplete. The whole ansi and stdio directory is
praktically empty, and what can you do with a C library without printf,
fread, fwrite etc?? The 1.5 distribution contains the files for ansi but these
files differ from the crcs in 1.6.24b. I don't want to use them, I wanted to
have a real 1.6.24b system! I started looking again on the FTP sites on
earlyer distributions but this time no luck. So now I'm stuck. I can only
build an unstable hybrid version of minix for which there is no future path,
which is not supported by Andy, and which may or may not work, Great.

There are several people beta-testing this version. How come they didn't miss
those files. How did they get them or did they have to buy the compiler to get
these?

It's fine with me, I know the patches are free and I shouldn't complain.
I only complain because I was told to upgrade from the net, and now that I
want to it appears it can't be done. Please don't tell the next one who
wants to start with the latest version of minix to upgrade from the net.

Kind Reagards,

Henk.

--
  /   /            Henk de Groot      | Dep.: IISS-SE (System Management)

/   / (-_ / / /(   Tel: +31 55 432104 | Digital Equipment Corporation

 
 
 

FATAL 1.6.24b (PC) Upgrade error, upgrade aborted!

Post by Will Ro » Wed, 03 Feb 1993 07:02:57



:
: Hello Netters,
:
: I own PC-Minix version 1.5 from Prentice Hall and wanted to upgrade to
: 1.6.24 (beta).
:
: Before I bought 1.5, I asked the net how to get the latest version of Minix.
: The advice I got was buy 1.5 and upgrade from the net. To my dissapointment
: this seems to be impossible!

Well, more or less impossible...  ast is looking at the current 1.6.24
and is collecting the problems found by the first testers, with the
intention of posting a fairly solid upgrade in due course (or so I
understand).  I myself have compiled 1.6.24 and even run it for a
couple of minutes before deciding it was too flakey for development,
and starting to work on the the Install script and the Makefiles.
Once they are done, then I will have a consistent and reliable build
process and can start beating on the code.  But others are way ahead
of me - I think Japan has done a great deal more.

The libraries, especially ansi, do seem a weak link with ACK 1.3.
I haven't had time to see just how weak, but I know some others have
taken a look and not much liked them.  It's a question of documenting
the problems and seeing what can be done to fix them.

The b at the end of 1.6.24b means beta, I'm afraid.  You have to watch
the net fairly closely to get some idea of the problems you're heading
into when you deal with an upgrade of this sort.  With luck, the next
version will be a bit less painful, but it will never be a walk in
the park.  Still, it keeps me off the streets (except at full moon).
Something to be thankful for.

Will


 
 
 

FATAL 1.6.24b (PC) Upgrade error, upgrade aborted!

Post by Henk de Gro » Sat, 06 Feb 1993 21:50:09



Quote:>Well, more or less impossible...  ast is looking at the current 1.6.24
>and is collecting the problems found by the first testers, with the
>[...]
>The libraries, especially ansi, do seem a weak link with ACK 1.3.
>I haven't had time to see just how weak, but I know some others have
>taken a look and not much liked them.  It's a question of documenting
>the problems and seeing what can be done to fix them.

I haven't tested the library yet, I got stuck in the generation already.
I wanted the build the whole 1.6.24b libc.a library from the bottom up,
but that's not possible.

I talked to ast about it and it seems that the only way to build a 'stable'
library is to build the *whole* library using the 1.5 makefile, header files
and library files, than switch the header files, install the Makefile.kr
and apply the patches and than run the Makefile to upgrade libc.a.
What you have at the end is a library half compiled with 1.5 and half
compiled with 1.6.24 and that should work (I assume).

Quote:>The b at the end of 1.6.24b means beta, I'm afraid.  You have to watch
>the net fairly closely to get some idea of the problems you're heading
>into when you deal with an upgrade of this sort.  With luck, the next
>version will be a bit less painful, but it will never be a walk in
>the park.  Still, it keeps me off the streets (except at full moon).
>Something to be thankful for.

I know this is a beta version, that why I jumped on this in the first place
to get it improved. From what I heard upto now, I don't expect any changes
with respect to the library problems for K&R users. What seems to count is
that it can be done (even it it's very clumsy) and that's it.

Kind Regards,

Henk.

--
  /   /            Henk de Groot      | Dep.: IISS-SE (System Management)

/   / (-_ / / /(   Tel: +31 55 432104 | Digital Equipment Corporation

 
 
 

1. PH1.5 -> 1.6.24b upgrade probs

I have been attempting to patch my virgin PH1.5 sources up to 1.6.24b.
Everything went ok until it came to the src/lib directories.  There
was almost nothing in the ansi.sh, or stdio.sh archives, yet there are
vast changes in the contents and organization of these directories.
In addition, three of the new directories, em, float, and math, have
only entries for a Makefile in the archives.

What gives? Is this new library arrangement only availiable for the
new ansi c compiler?  Surely the ansi and stdio directories at least
should be patched up for the k&r compiler.

richard~
--------

2. RAM upgrade problem on Plus

3. Version 1.6.24b upgrade problems

4. help: NT proxy server & Unix web server...

5. One more problem on 1.6.24b with K&R-C compiler (posix/_dup.c)

6. binary to float conversion

7. 1.6.24b with K&R-C (2) - commands

8. enable password

9. Request for help with 1.6.24b

10. 1.6.24b notes

11. Version 1.6.24b libc.a problems

12. lib/other/mtab.c (1.6.24b)

13. 1.6.24b update 2 [long]