Stub problem in 8.2.4 on NT - repost

Stub problem in 8.2.4 on NT - repost

Post by Tim Madde » Thu, 31 May 2001 04:06:25



Two weeks ago I configured my in house BIND 8.2.3 servers to
support the new.net TLDs by using stub zones.  Once I got it
running, it worked fine.  

Last week I upgraded to 8.2.4 and started getting the following
errors in named.log:

25-May-2001 16:06:16.000 load: info: hint zone "" (IN) loaded
(serial 0)
25-May-2001 16:06:17.000 load: warning: db_load could not open:
stubs/mp3: Errcode: 2: Errcode: 2: Errcode: 2: E

25-May-2001 16:06:17.000 load: info: hint zone "" (IN) loaded
(serial 0)
25-May-2001 16:06:18.000 load: warning: db_load could not open:
stubs/sport: Errcode: 2: Errcode: 2: Errcode: 2: E

Naturally, I couldn't resolve the new.net TLD zones.  I back revved
to 8.2.3NT3 and the stub networks work fine again.  No changes
were made to my config or zone files between versions and all
necessary directories exist.

--------------- named.conf ---------------
logging {
 channel named-log {
        file "c:\bind\logs\named.log" versions 5 size 3M;
        severity info;
        print-time yes;
        print-severity yes;
        print-category yes;
        };
[snip]

Quote:};

options {
 directory "c:\bind";
 pid-file ".\pid.txt";
 named-xfer "bin\named-xfer.exe";
 dump-file "logs\dump.txt";
 memstatistics-file "logs\memstats.txt";
 statistics-file "logs\stats.txt";
 notify yes;
 allow-recursion { 192.168/16; };
 allow-transfer { 192.168/16; };
 allow-query { 127.0.0/24; 192.168/16; };
 listen-on {192.168.50.16;};

Quote:};

zone "."                      IN {
        type hint;      
        file "db.cache.dom";

Quote:};

// The following line includes the root-stub zones promoted by
Newnet.com

INCLUDE "stubs\root-stubs.conf";

zone "0.0.127.IN-ADDR.ARPA"   IN {
        type master;    
        file "db.127.0.0.dom";

Quote:};

zone "aspenres.com"           IN {
        type master;    
        file "db.aspenres.com.dom";
Quote:};
};