HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!

HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!

Post by We R BOR » Thu, 08 Jan 1998 04:00:00



All,

when I try to build my program I get

getinfoDlg.obj : error LNK2001: unresolved external symbol

fatal error LNK1120: 1 unresolved externals
Error executing link.exe.

every thing looks finne what should I do?  Please Look at the code below

and let me know if anything is wrong.

{
NET_API_STATUS getinfo;
char buffername[30];
LPTSTR username, logon_domain, oth_domains, logon_server;
LPBYTE bufptr;
DWORD prefmaxlen;
short one1 = 1;
LPDWORD entriesread, totalentries, resumehandle;
WKSTA_USER_INFO_1 userinfo;

GetDlgItemText(IDC_COMPUTERNAME,m_computer);
strcpy(buffername,m_computer);
m_computer.MakeUpper();

getinfo = NetWkstaUserEnum(buffername, one1, &bufptr, prefmaxlen,
entriesread, totalentries, resumehandle);

 username = userinfo.wkui1_username;
 logon_domain = userinfo.wkui1_logon_domain;
 oth_domains = userinfo.wkui1_oth_domains;
 logon_server = userinfo.wkui1_logon_server;

Quote:}

Please help!!!!



  vcard.vcf
< 1K Download
 
 
 

HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!HELP!!!

Post by Pete Barre » Fri, 09 Jan 1998 04:00:00



>This is a multi-part message in MIME format.
>--------------3913D64A7848D814CE4B8BD2
>Content-Type: text/plain; charset=us-ascii
>Content-Transfer-Encoding: 7bit

>All,

>when I try to build my program I get

>getinfoDlg.obj : error LNK2001: unresolved external symbol

>fatal error LNK1120: 1 unresolved externals
>Error executing link.exe.

>every thing looks finne what should I do?  Please Look at the code below

>and let me know if anything is wrong.
>...

If it's a linker error, it's unlikely to be anything wrong with the code as
such. Check things like underscores (whether the linker expects them, and
whether they're prefixed on the library exports), that you're linking in the
right .LIB files that contain this particular function, that it's not expecting
a mangled name - things like that.

Otherwise, I note that NetWkstaUserEnum is an NT only function - assuming that
you're using NT, are you actually compiling for it?

Oh, and in future it's probably best if you use the subject line to give an idea
of what the problem is - 'HELP!!!HELP!!!HELP!!!...' may be quite amusing when
you write it, but there must have been a lot of people who could have helped
you, but didn't look at your message because they didn't realise they could.

Pete Barrett