Xp shows 'old' Samba server description

Xp shows 'old' Samba server description

Post by crai » Wed, 18 Jun 2003 03:02:24



Hi folks,

Bit of a weird one here. While I was setting up a RedHat 8.0 file
server, I set the server string to 'being set up' just in case anyone
came across it while browsing. I since changed it to 'file server' but
all the XP machines still show the old description in Explorer. In the
properties box for any shares etc., the correct name shows - it's just
in the 'summary' name in Explorer itself.

I have no idea why this is happening. Is it some kind of caching
problem with the master browser ? (NT3.51 PDC) I have restarted Samba
several times since the change.

TIA,

Craig

 
 
 

Xp shows 'old' Samba server description

Post by Walter Mautne » Wed, 18 Jun 2003 06:12:02


...

Quote:> came across it while browsing. I since changed it to 'file server' but
> all the XP machines still show the old description in Explorer. In the
> properties box for any shares etc., the correct name shows - it's just
> in the 'summary' name in Explorer itself.

> I have no idea why this is happening. Is it some kind of caching
> problem with the master browser ? (NT3.51 PDC) I have restarted Samba
> several times since the change.

Don't worry, it's XP storing the descriptions, probably in some registry
keas for "recent connections". Same effect here, with a pure samba pdc
network. You might want to delete each and every "my network places"
cached connection, and even then I am uncertain ...
--
WinXXP error#4711: NGSCB VIOLATION: Microsoft optical mouse detected penguin
patterns on mousepad. Background partition scan in progress to remove offending
incompatible products. Reactivate/recertify all MS products, 3 days grace.
http://www.cl.cam.ac.uk/~rja14/tcpa-faq.html

 
 
 

Xp shows 'old' Samba server description

Post by crai » Wed, 18 Jun 2003 21:12:05




> ...
> > came across it while browsing. I since changed it to 'file server' but
> > all the XP machines still show the old description in Explorer. In the
> > properties box for any shares etc., the correct name shows - it's just
> > in the 'summary' name in Explorer itself.

> > I have no idea why this is happening. Is it some kind of caching
> > problem with the master browser ? (NT3.51 PDC) I have restarted Samba
> > several times since the change.

> Don't worry, it's XP storing the descriptions, probably in some registry
> keas for "recent connections". Same effect here, with a pure samba pdc
> network. You might want to delete each and every "my network places"
> cached connection, and even then I am uncertain ...

Thanks!

It is indeed kept in the registry. To fix this, I disconnected the
network drives affected, then deleted the offending key from:

HKEY_CURRENT_USER\software\microsoft\windows\currentversion\explorer\computerdescriptions

After doing that, and logging out & back in, the correct description
was there.

Thanks again for your help.

CraigJ

 
 
 

1. Samba-server doesn't show up in 'Network Neighborhood'

I've been using Samba 2.0.5a for a while and everything was working fine,
but since last weekend my Samba-servers don't show up in the 'Network
Neighborhood'.
There were no changes in my smb.conf - files and even a restart of the nmbd
doesn't change
anything....

I also removed and readded my Samba-server from/to our NT-Domain, but no
change ...

can you help ??

Thanks
Christian

2. Russian charecters in setup project

3. Client doesn't show up as 'SMS Client' on SMS Server console

4. simple problem with waitforsingleobject

5. Old Pc's Showing Up

6. Money 2004 and Remote Desktop

7. XP Clients can't browse but can connect (1 of several XP query's)

8. palm V memory upgrade

9. XP can't 'see' a local modem

10. NT won't show Samba-server

11. Why doesn't the Samba server show up in Network Neighborhood?

12. Samba server doesn't show up in Networking Neighbourhood

13. SBS 4.5: XP clients don't show on the Network