'File already in use' using samba/access97 combo

'File already in use' using samba/access97 combo

Post by Leo Holmbe » Tue, 02 Mar 1999 04:00:00



First the particulars...

Samba Version 1.9.18p10,  running on an RS6000/ AIX 4.2.1.
Access 97 database.

We are trying to share an Access 97 data base using samba.

No matter what we do, we can't make the system give access to more than one
process at a time. For this section, I have turned off (I think) all the
file locking parameters I can find...i.e.

     read only = No
     locking = No
     oplocks = No

Running smbstatus reveals...

$ smbstatus
Samba version 1.9.18p10
Service      uid      gid      pid     machine
----------------------------------------------
ipp          brenda   ipp      12424   brenda
ipp          rmiller  ipp      12038   chip
ipp          jruth    ipp      11866   jon
ipp          jruth    ipp      12688   jon

Pid    DenyMode   R/W        Oplock           Name
--------------------------------------------------
12688  DENY_NONE  RDWR       NONE             system.mdw
12688  DENY_NONE  RDWR       NONE             IPP RF.mdb
12688  DENY_NONE  RDWR       NONE             system.ldb
12688  DENY_NONE  RDWR       NONE             IPP RF.ldb

However, when another client attempts to gain access they are given the
following message...

      "Couldn't use '\\aix1\ipp\system.mdw'; file already in use.

Does anyone have any experience sharing Access97 files with samba. I am posting
this to both microsoft.public.access.multiuser and comp.protocols.smb.

Leo Holmberg

Does anyone have any experience sharing access files with samba. I am posting
this to both microsoft.public.access.multiuser and comp.1

 
 
 

1. Modem log files being 'shortened' by server (using Time-On-Line 3.6)

Hello!

I regularly review our NT servers modem logs. However, one of the logs (for
our main DUN modem) is being regularly 'part-erased'. I cannot see any
reason for this - can anyone else suggest a solution?

BTW, I am using a registered version of 'Time On Line' (v3.6) to analyse the
logs, if that make a difference.

Thanks

Neil

2. Large drives > 1024 and FAT.

3. Anyone using Samba on NeXTStep 3.0/68040 'pizza box'

4. SupraFaxModem : discontinued ?

5. Can't get attribute values using LDAP (using VB) to non-MS LDAP server

6. Problem linking in Project Builder.

7. POP3 Connector using 'Router' connection

8. how to make \mathit{} the default math font

9. 'Unable to send mail now' error when using SBS console to force mail run.

10. SMTP Mail using 'finger'

11. Automatic dialup using a scheduled 'ping'

12. Exporting 'Query Result' using Admin Console.

13. error using 'cd' in smbclient