Cisco 804 ISDN Router won't answer some voice calls

Cisco 804 ISDN Router won't answer some voice calls

Post by Kevin Pier » Tue, 08 Jul 2003 21:39:55



I am unable to get my Cisco 804 ISDN router to answer incoming voice
calls when the line is previously engaged in a data call.

It will answer voice when NO data call is engaged.
It will allow interruption of data call for OUTGOING voice call.

But it will not interrupt a data call for an incoming voice call.
Incoming caller hears busy signal. I've tried a variety of analog
devices on both POTS ports, to no avail.

All other operations are fine.

IOS is 12.0(5)T. Configuration follows...

Any suggestions are appreciated.

Kevin Pierce

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname XXX
!
logging buffered 8192 debugging
no logging console
enable secret XXX
!
username XXX password XXX
!
!
!
!
!
dial-peer voice 1 pots
 forward-to-unused-port
 no call-waiting
 ring 0
 port 1
 destination-pattern 332XXXX
!
dial-peer voice 2 pots
 forward-to-unused-port
 no call-waiting
 ring 0
 port 2
 destination-pattern 332YYYY
!
pots country US
ip subnet-zero
no ip source-route
!
ip dhcp pool DHCPPoolLAN_0
   network 192.168.0.0 255.255.255.0
   dns-server 138.210.81.3 205.160.188.2
   default-router 192.168.0.1
!
ip name-server 138.210.81.3
ip name-server 205.160.188.2
isdn switch-type basic-ni
!
!
process-max-time 200
!
interface Ethernet0
 ip address 192.168.0.1 255.255.255.0
 ip access-group 121 in
 no ip directed-broadcast
 no ip proxy-arp
 ip nat inside
!
interface BRI0
 no ip address
 no ip directed-broadcast
 encapsulation ppp
 dialer pool-member 1
 isdn switch-type basic-ni
 isdn spid1 941332XXXX0101 332XXXX
 isdn spid2 941332YYYY0101 332YYYY
 isdn voice-priority 332XXXX out always
 isdn voice-priority 332XXXX in always
 isdn voice-priority 332YYYY out always
 isdn voice-priority 332YYYY in always
 isdn incoming-voice modem
 ppp authentication chap pap callin
 ppp multilink
!
interface Dialer0
 no ip address
 no ip directed-broadcast
 no cdp enable
!
interface Dialer1
 description ISP
 ip address negotiated
 ip access-group 121 in
 no ip directed-broadcast
 no ip proxy-arp
 ip nat outside
 encapsulation ppp
 no ip split-horizon
 dialer remote-name Cisco1
 dialer idle-timeout 300
 dialer string 656ZZZZ class DialClass
 dialer hold-queue 10
 dialer load-threshold 1 either
 dialer pool 1
 dialer-group 1
 pulse-time 0
 ppp authentication chap pap callin
 ppp chap hostname XXXX
 ppp chap password XXXX
 ppp pap sent-username XXXX password XXXX
 ppp multilink
!
ip nat inside source list 18 interface Dialer1 overload
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
map-class dialer DialClass
access-list 18 permit 192.168.0.0 0.0.0.255
access-list 121 deny   udp any eq netbios-dgm any
access-list 121 deny   udp any eq netbios-ns any
access-list 121 deny   udp any eq netbios-ss any
access-list 121 deny   tcp any eq 137 any
access-list 121 deny   tcp any eq 138 any
access-list 121 deny   tcp any eq 139 any
access-list 121 permit ip any any time-range TIME
dialer-list 1 protocol ip permit
!
line con 0
 exec-timeout 0 0
 transport input none
 stopbits 1
line vty 0 4
 exec-timeout 0 0
 login local
!
time-range TIME
 periodic daily 0:00 to 23:59
!
end

 
 
 

Cisco 804 ISDN Router won't answer some voice calls

Post by J Flyn » Tue, 22 Jul 2003 09:59:36


Kevin,

Do a google "group search" for cisco 804 voice priority.
I have the same problem but on a retail basis I can only find 12.0.5 for
sale and
I'm not going to pay 150+ for a later IOS release!  If any on wants to share
a working release pls advise.

John

Quote:> I am unable to get my Cisco 804 ISDN router to answer incoming voice
> calls when the line is previously engaged in a data call.

> It will answer voice when NO data call is engaged.
> It will allow interruption of data call for OUTGOING voice call.

> But it will not interrupt a data call for an incoming voice call.
> Incoming caller hears busy signal. I've tried a variety of analog
> devices on both POTS ports, to no avail.

> All other operations are fine.

> IOS is 12.0(5)T. Configuration follows...

> Any suggestions are appreciated.

> Kevin Pierce

> !
> version 12.0
> no service pad
> service timestamps debug uptime
> service timestamps log uptime
> service password-encryption
> !
> hostname XXX
> !
> logging buffered 8192 debugging
> no logging console
> enable secret XXX
> !
> username XXX password XXX
> !
> !
> !
> !
> !
> dial-peer voice 1 pots
>  forward-to-unused-port
>  no call-waiting
>  ring 0
>  port 1
>  destination-pattern 332XXXX
> !
> dial-peer voice 2 pots
>  forward-to-unused-port
>  no call-waiting
>  ring 0
>  port 2
>  destination-pattern 332YYYY
> !
> pots country US
> ip subnet-zero
> no ip source-route
> !
> ip dhcp pool DHCPPoolLAN_0
>    network 192.168.0.0 255.255.255.0
>    dns-server 138.210.81.3 205.160.188.2
>    default-router 192.168.0.1
> !
> ip name-server 138.210.81.3
> ip name-server 205.160.188.2
> isdn switch-type basic-ni
> !
> !
> process-max-time 200
> !
> interface Ethernet0
>  ip address 192.168.0.1 255.255.255.0
>  ip access-group 121 in
>  no ip directed-broadcast
>  no ip proxy-arp
>  ip nat inside
> !
> interface BRI0
>  no ip address
>  no ip directed-broadcast
>  encapsulation ppp
>  dialer pool-member 1
>  isdn switch-type basic-ni
>  isdn spid1 941332XXXX0101 332XXXX
>  isdn spid2 941332YYYY0101 332YYYY
>  isdn voice-priority 332XXXX out always
>  isdn voice-priority 332XXXX in always
>  isdn voice-priority 332YYYY out always
>  isdn voice-priority 332YYYY in always
>  isdn incoming-voice modem
>  ppp authentication chap pap callin
>  ppp multilink
> !
> interface Dialer0
>  no ip address
>  no ip directed-broadcast
>  no cdp enable
> !
> interface Dialer1
>  description ISP
>  ip address negotiated
>  ip access-group 121 in
>  no ip directed-broadcast
>  no ip proxy-arp
>  ip nat outside
>  encapsulation ppp
>  no ip split-horizon
>  dialer remote-name Cisco1
>  dialer idle-timeout 300
>  dialer string 656ZZZZ class DialClass
>  dialer hold-queue 10
>  dialer load-threshold 1 either
>  dialer pool 1
>  dialer-group 1
>  pulse-time 0
>  ppp authentication chap pap callin
>  ppp chap hostname XXXX
>  ppp chap password XXXX
>  ppp pap sent-username XXXX password XXXX
>  ppp multilink
> !
> ip nat inside source list 18 interface Dialer1 overload
> no ip http server
> ip classless
> ip route 0.0.0.0 0.0.0.0 Dialer1
> !
> !
> map-class dialer DialClass
> access-list 18 permit 192.168.0.0 0.0.0.255
> access-list 121 deny   udp any eq netbios-dgm any
> access-list 121 deny   udp any eq netbios-ns any
> access-list 121 deny   udp any eq netbios-ss any
> access-list 121 deny   tcp any eq 137 any
> access-list 121 deny   tcp any eq 138 any
> access-list 121 deny   tcp any eq 139 any
> access-list 121 permit ip any any time-range TIME
> dialer-list 1 protocol ip permit
> !
> line con 0
>  exec-timeout 0 0
>  transport input none
>  stopbits 1
> line vty 0 4
>  exec-timeout 0 0
>  login local
> !
> time-range TIME
>  periodic daily 0:00 to 23:59
> !
> end


 
 
 

Cisco 804 ISDN Router won't answer some voice calls

Post by Kevin Pierc » Wed, 23 Jul 2003 22:13:36


Turns out it was the Telco (Sprint). CSV/ACO had been order (and put on my
bill), but the instruction hadn't made it to the switch. Additional Call
Offering made the incoming fax calls interrupt b2 data just fine.

Kevin


> Kevin,

> Do a google "group search" for cisco 804 voice priority.
> I have the same problem but on a retail basis I can only find 12.0.5 for
> sale and
> I'm not going to pay 150+ for a later IOS release!  If any on wants to
share
> a working release pls advise.

> John


> > I am unable to get my Cisco 804 ISDN router to answer incoming voice
> > calls when the line is previously engaged in a data call.

> > It will answer voice when NO data call is engaged.
> > It will allow interruption of data call for OUTGOING voice call.

> > But it will not interrupt a data call for an incoming voice call.
> > Incoming caller hears busy signal. I've tried a variety of analog
> > devices on both POTS ports, to no avail.

> > All other operations are fine.

> > IOS is 12.0(5)T. Configuration follows...

> > Any suggestions are appreciated.

> > Kevin Pierce

> > !
> > version 12.0
> > no service pad
> > service timestamps debug uptime
> > service timestamps log uptime
> > service password-encryption
> > !
> > hostname XXX
> > !
> > logging buffered 8192 debugging
> > no logging console
> > enable secret XXX
> > !
> > username XXX password XXX
> > !
> > !
> > !
> > !
> > !
> > dial-peer voice 1 pots
> >  forward-to-unused-port
> >  no call-waiting
> >  ring 0
> >  port 1
> >  destination-pattern 332XXXX
> > !
> > dial-peer voice 2 pots
> >  forward-to-unused-port
> >  no call-waiting
> >  ring 0
> >  port 2
> >  destination-pattern 332YYYY
> > !
> > pots country US
> > ip subnet-zero
> > no ip source-route
> > !
> > ip dhcp pool DHCPPoolLAN_0
> >    network 192.168.0.0 255.255.255.0
> >    dns-server 138.210.81.3 205.160.188.2
> >    default-router 192.168.0.1
> > !
> > ip name-server 138.210.81.3
> > ip name-server 205.160.188.2
> > isdn switch-type basic-ni
> > !
> > !
> > process-max-time 200
> > !
> > interface Ethernet0
> >  ip address 192.168.0.1 255.255.255.0
> >  ip access-group 121 in
> >  no ip directed-broadcast
> >  no ip proxy-arp
> >  ip nat inside
> > !
> > interface BRI0
> >  no ip address
> >  no ip directed-broadcast
> >  encapsulation ppp
> >  dialer pool-member 1
> >  isdn switch-type basic-ni
> >  isdn spid1 941332XXXX0101 332XXXX
> >  isdn spid2 941332YYYY0101 332YYYY
> >  isdn voice-priority 332XXXX out always
> >  isdn voice-priority 332XXXX in always
> >  isdn voice-priority 332YYYY out always
> >  isdn voice-priority 332YYYY in always
> >  isdn incoming-voice modem
> >  ppp authentication chap pap callin
> >  ppp multilink
> > !
> > interface Dialer0
> >  no ip address
> >  no ip directed-broadcast
> >  no cdp enable
> > !
> > interface Dialer1
> >  description ISP
> >  ip address negotiated
> >  ip access-group 121 in
> >  no ip directed-broadcast
> >  no ip proxy-arp
> >  ip nat outside
> >  encapsulation ppp
> >  no ip split-horizon
> >  dialer remote-name Cisco1
> >  dialer idle-timeout 300
> >  dialer string 656ZZZZ class DialClass
> >  dialer hold-queue 10
> >  dialer load-threshold 1 either
> >  dialer pool 1
> >  dialer-group 1
> >  pulse-time 0
> >  ppp authentication chap pap callin
> >  ppp chap hostname XXXX
> >  ppp chap password XXXX
> >  ppp pap sent-username XXXX password XXXX
> >  ppp multilink
> > !
> > ip nat inside source list 18 interface Dialer1 overload
> > no ip http server
> > ip classless
> > ip route 0.0.0.0 0.0.0.0 Dialer1
> > !
> > !
> > map-class dialer DialClass
> > access-list 18 permit 192.168.0.0 0.0.0.255
> > access-list 121 deny   udp any eq netbios-dgm any
> > access-list 121 deny   udp any eq netbios-ns any
> > access-list 121 deny   udp any eq netbios-ss any
> > access-list 121 deny   tcp any eq 137 any
> > access-list 121 deny   tcp any eq 138 any
> > access-list 121 deny   tcp any eq 139 any
> > access-list 121 permit ip any any time-range TIME
> > dialer-list 1 protocol ip permit
> > !
> > line con 0
> >  exec-timeout 0 0
> >  transport input none
> >  stopbits 1
> > line vty 0 4
> >  exec-timeout 0 0
> >  login local
> > !
> > time-range TIME
> >  periodic daily 0:00 to 23:59
> > !
> > end

---
Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.500 / Virus Database: 298 - Release Date: 7/10/2003