.forward fails

.forward fails

Post by Peter Kolt » Thu, 18 Jun 1998 04:00:00



Hi,

~/.forward files don't work since sendmail 8.9.0 was installed (IRIX 6.4).
I checked / /etc /etc/mail /usr /var /var/spool /var/spool/mqueue
directories whether they are group-writable (not any more), commented the
O ForwardPath in /etc/sendmail.cf hoping that the default is ~/.forward .
The mails are delivered locally, and are not forwarded.

-------
Fragments of
/etc/sendmail.cf:

# level 8 config file format
V8/Berkeley

O DontBlameSendmail=forwardfileinunsafedirpath,
                forwardfileinunsafedirpathsafe

# Configuration version number
DZ8.9.0

# Forward file search path
O ForwardPath=$z/.forward.$w+$h:$z/.forward+$h:$z/.forward.$w:$z/.forward

SYSLOG: (when restarting sendmail)

Jun 17 00:26:07 5B:infosys sendmail: starting
Jun 17 00:26:07 5B:infosys sendmail: Frozen configurations unsupported
Jun 16 23:26:07 6C:infosys sendmail[11356]: starting daemon (8.9.0):

Jun 16 23:26:07 5C:infosys sendmail[9427]: alias database /etc/aliases
rebuilt by koltl
Jun 16 23:26:07 2C:infosys sendmail[9427]: NOQUEUE: SYSERR(root):
/etc/aliases:
line 13: endrey... cannot alias non-local names


-rwsr-sr-x    1 root     sys       556120 Jun  4 00:17 /usr/lib/sendmail
-rwsr-xr-x    1 root     sys       259276 Apr 30  1997
/usr/lib/sendmail.IRIXorig
lrwxrwxrwx    1 root     sys           21 Dec 27  1996
/usr/lib/sendmail.cf -> ../../etc/sendmail.cf
lrwxrwxrwx    1 root     sys           21 Dec 27  1996
/usr/lib/sendmail.hf -> ../../etc/sendmail.hf


-rw-r--r--    1 root     sys        27612 Jun 16 23:52 /etc/sendmail.cf

The machine is a NIS server and there are some problems with aliases map,
but can it be related?

What's wrong? Thanks for your help.

Peter

 
 
 

.forward fails

Post by Koltl Pete » Fri, 19 Jun 1998 04:00:00



> ~/.forward files don't work since sendmail 8.9.0 was installed (IRIX 6.4).
> I checked / /etc /etc/mail /usr /var /var/spool /var/spool/mqueue
> directories whether they are group-writable (not any more), commented the
> O ForwardPath in /etc/sendmail.cf hoping that the default is ~/.forward .
> The mails are delivered locally, and are not forwarded.

Solution found:

/etc/sendmail.cf :
Mlocal, P=/bin/mail, F=EDFMAlsw, S=10, R=20, A=mail -s -d $u
                              ^

(
http://falbala.informatik.uni-kiel.de/~ca/email/doc8.9/op-sh-5.html#sh-5
)

Quote:> SYSLOG: (when restarting sendmail)

...
> line 13: endrey... cannot alias non-local names

For aliases, flag A is needed ( F=EDFMAlsw )
                                      ^

Peter

 
 
 

1. compose works, reply/forward fail

I have figured out the problem and it was my PPPoE driver that came with
WindowsXP. Apparently this is quite common for some reason with PPPoE on
DSL. The fix was to install an unbundled RASPPPoE. It was not a pine
problem at all, but that was where it manifested itself. I guess the
original PPPoE can handle incredibly small data, and that is why newly
composed messages seemed to work.

-bill

2. Color Laser Copier Newsgroup?

3. Configuring sendmail to forward failed mail

4. CH-101G ISA IDE Caching Disk Controller Plus I/O. Help Needed

5. Forwarding fails in Sendmail 5.65c+IDA-1.4.4

6. VS.NET removes my code

7. forwarding failed messages to another user

8. .forward fails intermittently

9. procmail forwards fail (wrong smtp server?)

10. Default forwarding if local aliases fail

11. forward to smarthost if local delivery fails

12. forward or fail gracefully