Mailbox corruption

Mailbox corruption

Post by Damian Mensche » Thu, 20 Dec 2001 09:18:48



Trying to track down an odd bug....

I am using Pine (4.33) to connect to Exchange (5.5.2653.13) through
IMAP.  I generally save my outgoing messages to a folder, and also
often take advantage of the pOstpone feature.

I've noticed, however, that outgoing messages (either saved to a
folder when sent, or saved to the postponed-msgs folder) are often
getting corrupted.  The nature of the corruption is that the end
of the message will appear before the beginning (including headers).

For example, this happened today:
-------------------------------- cut here ---------------------------
#=-
-=#| 1412C DCL, Workstation Services Group, CCSO Ofc:(217)244-3862 |#=-

Date: Tue, 18 Dec 2001 14:00:37 -0600 (CST)




Subject: Re: SGI surplus

Message-ID:

MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII


> That must be a common occurance, the last couple of Indys we have
gotten
> rid of had bad power supplies.  I will keep your name and number
should
> any come my way to surplus and or scrap.

It is *very* common.  I currently have four dead Indy power supplies on
my shelf.  I'm hoping to figure out how to fix them some day....

Thanks,

Damian Menscher
--

-=#| 488 LLP, 1110 W. Green St, Urbana, IL 61801 Ofc:(217)333-0038 |
-------------------------------- cut here ---------------------------
(space removed from after the sigdashes above to prevent issues
with people's newsreaders truncating the rest of my message)

I think it's somewhat suspicious that the first 1000 characters of
the message (including headers) are stored together (though moved
to the end.  I'm told that Exchange uses a database to store mail
files... perhaps this is related?

And yes, the messages are corrupt on the server.  Viewing them
using LookOut or the web interface shows the same corruption.

I'd be very interested to hear if anyone has experienced anything
similar.  Right now, I don't know whether the problem is with Pine
or with Exchange.  But it's something we've been seeing off-and-on
for about a year, so it would be really nice to track down!

Damian Menscher
--

-=#| 488 LLP, 1110 W. Green St, Urbana, IL 61801 Ofc:(217)333-0038 |#=-
-=#| 1412C DCL, Workstation Services Group, CCSO Ofc:(217)244-3862 |#=-

 
 
 

1. Eudora: continuous mailbox corruption

Continuous "Corrupted Mailbox" message upon launching
Eudora Pro 2.1, (Windows Workgroups 3.11), and other error messages such as
"Error during Flush" and "Damaged Table of Contents".
Inbox and outbox only affected. Deletion of mailboxes in.toc/mbx
and out.toc/mbx and restarting Eudora clears the problem temporarily.
Virus software running and System checked.  Any suggestions appreciated.

2. Office 2000 Shutting NT4.0 down

3. Mailbox Corruption

4. Servlets

5. Mailbox corruption

6. SBS 4.5 Console fails to load

7. Sendmail 8.6.8 mailbox corruption

8. intel motherboard -having 845GL chipset - verfiying claim without opening cabinet

9. mbx mailbox corruption and quotas?

10. menu&toolbar corruption

11. OE password corruption

12. Video Corruption