Mailbox corruption

Mailbox corruption

Post by Shtirlit » Thu, 26 Oct 2000 04:00:00



Hello!

I've noticed in my /var/log/maillog file the following string

Oct 25 09:43:44 astnet cucipop[44901]: mailbox pirelli corrupted at
12106440

Is there any way to fix the mailbox?

 
 
 

Mailbox corruption

Post by Andrzej Fili » Sat, 28 Oct 2000 06:22:00



> Hello!

> I've noticed in my /var/log/maillog file the following string

> Oct 25 09:43:44 astnet cucipop[44901]: mailbox pirelli corrupted at
> 12106440

> Is there any way to fix the mailbox?

One way to fix the problem:
1) move the mailbox file to another location
2) send new message to the address
[ mailbox file will be recreated (in most configurations)]
3) try to retrieve messages from the old mailbox file
I think you may use formail

--
Andrzej (Andrew) A. Filip         http://bigfoot.com/~anfi


Feel free to correct the post if YOU think it is required.

 
 
 

1. Mailbox corruption

Trying to track down an odd bug....

I am using Pine (4.33) to connect to Exchange (5.5.2653.13) through
IMAP.  I generally save my outgoing messages to a folder, and also
often take advantage of the pOstpone feature.

I've noticed, however, that outgoing messages (either saved to a
folder when sent, or saved to the postponed-msgs folder) are often
getting corrupted.  The nature of the corruption is that the end
of the message will appear before the beginning (including headers).

For example, this happened today:
-------------------------------- cut here ---------------------------
#=-
-=#| 1412C DCL, Workstation Services Group, CCSO Ofc:(217)244-3862 |#=-

Date: Tue, 18 Dec 2001 14:00:37 -0600 (CST)




Subject: Re: SGI surplus

Message-ID:

MIME-Version: 1.0
Content-Type: TEXT/PLAIN; charset=US-ASCII

It is *very* common.  I currently have four dead Indy power supplies on
my shelf.  I'm hoping to figure out how to fix them some day....

Thanks,

Damian Menscher
--

-=#| 488 LLP, 1110 W. Green St, Urbana, IL 61801 Ofc:(217)333-0038 |
-------------------------------- cut here ---------------------------
(space removed from after the sigdashes above to prevent issues
with people's newsreaders truncating the rest of my message)

I think it's somewhat suspicious that the first 1000 characters of
the message (including headers) are stored together (though moved
to the end.  I'm told that Exchange uses a database to store mail
files... perhaps this is related?

And yes, the messages are corrupt on the server.  Viewing them
using LookOut or the web interface shows the same corruption.

I'd be very interested to hear if anyone has experienced anything
similar.  Right now, I don't know whether the problem is with Pine
or with Exchange.  But it's something we've been seeing off-and-on
for about a year, so it would be really nice to track down!

Damian Menscher
--

-=#| 488 LLP, 1110 W. Green St, Urbana, IL 61801 Ofc:(217)333-0038 |#=-
-=#| 1412C DCL, Workstation Services Group, CCSO Ofc:(217)244-3862 |#=-

2. UNIX AMIPRO viewer needed

3. Eudora: continuous mailbox corruption

4. FP2K Mgmt Tool for Updating Graphics?

5. Mailbox Corruption

6. SQLDescribeParam() always reture SQL_VARCHAR

7. Sendmail 8.6.8 mailbox corruption

8. mbx mailbox corruption and quotas?

9. menu&toolbar corruption

10. OE password corruption

11. Video Corruption