Installer Package doesn't reboot via PCMWIN16 on Win95 Client

Installer Package doesn't reboot via PCMWIN16 on Win95 Client

Post by Tom » Sat, 20 Dec 1997 04:00:00



Hi All,

has anyone experienced a problem where an SMS Installer executable
configured to reboot a client machine using RESTART W, S or E... fails to
restart when submitted to Windows 95 machines through SMS as a workstations
job. The shutdown process starts, but PCM won't close (it hangs basically).
If I End Task on PCM then the restart process completes successfully.

I have my Destination Platforms set for Win16/Win32, the Suppress Reboot
Message option is selected, the /S switch is being used for the package
command-line.

Also, if I run the installer created EXE manually from the package
directory on the distribution server it restarts appropriately and if I
open PCM and then run the EXE from the package directory manually it will
close the PCMWIN16 window and restart properly. I only have this problem if
I run the executable via PCMWIN16.

Any thoughts???

Thanks in advance.

 
 
 

Installer Package doesn't reboot via PCMWIN16 on Win95 Client

Post by Karl » Fri, 26 Dec 1997 04:00:00


Don't attempt any silent background install with a reboot using the RESTART
environment variable. I also did this and had the installation 'hang' and
subsequently reinstall the package every time the user logged back in
because the PCM service kept getting 'killed' by the restart command before
it could tell the server it was done.

What I've been told by a MS rep. was to bundle the executable in a batch
file running the SHUTDOWN utility last.

Another thing I noticed was SMS installer doesn't check to see if a text
string already exists before appending it to the system path (like the Help
screen said it does), the application I had that kept re-installing also
kept adding its path string again and again and ....

Enjoy!
Karl

.


>Hi All,

>has anyone experienced a problem where an SMS Installer executable
>configured to reboot a client machine using RESTART W, S or E... fails to
>restart when submitted to Windows 95 machines through SMS as a workstations
>job. The shutdown process starts, but PCM won't close (it hangs basically).
>If I End Task on PCM then the restart process completes successfully.

>I have my Destination Platforms set for Win16/Win32, the Suppress Reboot
>Message option is selected, the /S switch is being used for the package
>command-line.

>Also, if I run the installer created EXE manually from the package
>directory on the distribution server it restarts appropriately and if I
>open PCM and then run the EXE from the package directory manually it will
>close the PCMWIN16 window and restart properly. I only have this problem if
>I run the executable via PCMWIN16.

>Any thoughts???

>Thanks in advance.


 
 
 

1. Win95 'map network drive at logon' doesn't work when I use DHCP?

I've been using samba to map my home directory on an rs/6000 to a drive
on my Win95 PC.  It's always worked fine, including the 'reconnect at
logon' option.

I just switched my machine to get its IP configuration via DHCP from a
linux system.  The DHCP stuff works fine, but now my samba drive doesn't
mount (it shows up in 'my computer', but can't access it).  If I then
map the drive manually, it works.

Is there something about the order in which Win95 processes DHCP and
network mappings at startup that makes this not work?  Is there
something I can do to get it to work again?

--
Rob Yampolsky
Columbine JDS Systems, Inc.

2. XBOX extended warranty

3. Client doesn't show up as 'SMS Client' on SMS Server console

4. GSM Roaming Experiences

5. One client doesn't receive Internet Mail via MS Exchange

6. Bitmap editor

7. Preventing Installer packages from automatically rebooting.

8. Cisco, pcAnywhere and NAT Question?

9. Reboot via Package Command Manager

10. SMTP Virtual Server doesn't start after reboot

11. I create a NEW collection and it doesn't show up till reboot

12. Samba doesn't restart upon reboot

13. installer reboot won't pass security logon banner