Unable to register SMTP OnPostCategorize sink

Unable to register SMTP OnPostCategorize sink

Post by Mark Kub » Fri, 10 Nov 2000 04:00:00



I am having problems with the SMTPREG.VBS script when attempting to register
a sink for SMTP's OnPostCategorize event.  I can register the sink (with
appropriate interfaces added or changed) for OnTransportSubmission,
OnCategorize, and OnPreCategorize, but OnPostCategorize just does not seem
to work.  The script displays success, but when I go back and enumerate the
sink bindings, it is not there.

Is there something different about OnPostCategorize, or is something just
plain broken?

Mark Kubo

 
 
 

Unable to register SMTP OnPostCategorize sink

Post by Lloyd Macroho » Thu, 23 Nov 2000 12:14:05


The CATID for PostCategorize in the smtpreg.vbs script is incorrect

    Const catidSmtpOnPostCategorize          =
"{76719654-05A6-11d2-9E00-00C04FA322BA}"
Should be:
    Const catidSmtpOnPostCategorize          =
"{76719654-05A6-11D2-9DFD-00C04FA322BA}"

Lloyd


> I am having problems with the SMTPREG.VBS script when attempting to
register
> a sink for SMTP's OnPostCategorize event.  I can register the sink (with
> appropriate interfaces added or changed) for OnTransportSubmission,
> OnCategorize, and OnPreCategorize, but OnPostCategorize just does not seem
> to work.  The script displays success, but when I go back and enumerate
the
> sink bindings, it is not there.

> Is there something different about OnPostCategorize, or is something just
> plain broken?

> Mark Kubo



 
 
 

1. Adding recipients in OnPostCategorize sink

I'm experimenting with SMTP transport event sinks to add or replace
recipients during the PostCategorize sink. I've build a simple event sink
that adds an additional recipient using the sample code from MSDN. This
works well on a machine without Exchange. However, when I run my sink on an
Exchange box, the message is never delivered to the additional recipient. If
I use a Yahoo e-mail address, the message is rejected outright, with Yahoo's
smtp server complaining of stray new lines. With other e-mail addresses the
SMTP conversation typically just times out, as if the destination server
could not detect end of message body.

The problem only occurs with the "extra" recipient added in the post cat
sink. I can send normal messages just fine.

Has anyone seen this behavior or can point out some ways to further debug
the problem?

-Igor

2. OUTLOOK Configuration problems

3. unable to list recipients from a SMTP Event sink OnInBoundCommand

4. Default Email Alias

5. Problems registering workflow sinks

6. Connection Problem

7. Problem registering event sinks

8. Q: How to Automatically book resources EXCH 5.0

9. Registering an event sink

10. Couldn't register store evenk sinks

11. Problem Registering Storage Event Sink on MBX folder

12. SEO.dll Register Sink