Primary NT Account changed for no reason

Primary NT Account changed for no reason

Post by Peter Hutchinso » Fri, 24 Oct 2003 18:20:16



Morning All

Come in this morning to find that the primary windows NT
accounts on my Exch 5.5 server had been changed to
Accounts that are on an Exchange 2000 server that is
connected to my site via WAN. Does anyone have an
explanation of why this happens.

Thanks
Peter  

 
 
 

Primary NT Account changed for no reason

Post by Serene Verghes » Sat, 25 Oct 2003 00:25:54


Have your NT 4.0 accounts been migrated to W2K domains along with SID
history?
The exch 5.5 directory stores the NT SID as a property of the mailbox
(NT-Security-identifier).For viewing in the GUI, the SID is resolved to a
display name.
It might be resolving the SID to the account in the AD, perhaps because that
domain is listed higher alphabetically that the NT 4.0 domain. (I may be
wrong here...I'm making a few assumptions based on my observations of what
happened within my org)
HTH
Serene


Quote:> Morning All

> Come in this morning to find that the primary windows NT
> accounts on my Exch 5.5 server had been changed to
> Accounts that are on an Exchange 2000 server that is
> connected to my site via WAN. Does anyone have an
> explanation of why this happens.

> Thanks
> Peter


 
 
 

1. Exchange 5.5/Exchange 2000 Primary NT Account change

One site in our organisation contains a mixture of Exchange 5.5/Exchange
2000 servers and was created from scratch in the following sequence:

        An Exchange 5.5 server was used to create a new site within the
organisation and act as the bridgehead server onto the other sites.

        The server acts as the target for an ADC used to populate a
Windows 2000 AD with disabled user accounts.

        The site was populated by using the 'move server wizard' to shift
two Exchange 5.5 servers into the new site from other existing sites in the
organisation.

        Exchange 2000 servers where then added to the new site and the
'move mailbox wizard' used to transferred mailboxes from Exchange 5.5 to
Exchange 2000.

        Finally the Exchange 5.5 servers which used to contain the
mailboxes where removed from the site.

        After a bit of fiddling about everything worked fine.  I know it
would have been much simpler to put Exchange 2000 servers into the existing
sites - but that's politics for you!!

However, we now have two problems - one in Exchange 5.5 and one in Exchange
2000.

Exchange 5.5

Since the site was created the Primary Windows NT Account for a large group
of users (about 5500) has been changed and each user has ended up with the
old Primary Account appearing in the 'Permissions/Windows NT Accounts with
Permissions' dialogue box with a 'custom' Mailbox owner role.  We need to
get rid of these but can't get at them using directory import or export as
they don't appear under either the Obj-Admins, Obj-Perm-Admins or Obj-Users
pseudo-attribute fields.  Any ideas on how we can delete these entries in
bulk?

Exchange 2000

The change of Primary Windows NT Account is not being replicated through to
the AD Exchange Advanced/Mailbox Rights entry and the original NT account is
still attributed with the all important 'Associated External Account'
permission.  Even if we manually delete the original account in Exchange 5.5
the AD settings do not change.  It's impractical to change the Rights
manually as it takes 2-3 minutes to resolve the various account names before
they can be edited!  Any ideas on how to force the changes into AD?

Help with either/both problems would be much appreciated.


2. 16bit exchange client

3. Long delay for Outlook connect when Primary Windows NT Account changed

4. Notification problem

5. Changing primary NT account

6. SMTP

7. Anyone running their own ILS and using NetMeeting via Exchange?

8. Permission Denied after changing primary windows NT account on a mailbox

9. Changing Primary Windows NT Account

10. Changing Primary NT Account in Mailbox

11. Change Primary NT Account - Delay??

12. Change Primary Windows NT Account - Delay??