TLS handshake

TLS handshake

Post by Andrew Lessi » Wed, 03 Jul 2002 17:24:47



From about 2 week I have problems receiving e-mail from some senders.

They get this error :

     ----- The following addresses had permanent fatal errors -----

     (reason: 403 4.7.0 TLS handshake failed.)

     ----- Transcript of session follows -----

handshake failed.
  Message could not be delivered for 1 day
  Message will be deleted from queue

Someone tells me that it is a STARTTLS related problem.
What can I check on my server SBS2000 (Exchange 2000 SP2) to find out the
cause ?

 
 
 

TLS handshake

Post by MVP » Thu, 04 Jul 2002 00:17:31


Have you looked at http://www.sendmail.org/~ca/email/starttls.html.

--
John Oliver, Jr.
MCSE, MCT, CCNA, Exchange MVP


> From about 2 week I have problems receiving e-mail from some senders.

> They get this error :

>      ----- The following addresses had permanent fatal errors -----

>      (reason: 403 4.7.0 TLS handshake failed.)

>      ----- Transcript of session follows -----

> handshake failed.
>   Message could not be delivered for 1 day
>   Message will be deleted from queue

> Someone tells me that it is a STARTTLS related problem.
> What can I check on my server SBS2000 (Exchange 2000 SP2) to find out the
> cause ?


 
 
 

TLS handshake

Post by Andrew Lessi » Fri, 05 Jul 2002 19:51:47


The sender tells me it's an Exchange bug.
How to understand if the problem is from my side or by sender's side ?



> Have you looked at http://www.sendmail.org/~ca/email/starttls.html.

> --
> John Oliver, Jr.
> MCSE, MCT, CCNA, Exchange MVP



> > From about 2 week I have problems receiving e-mail from some senders.

> > They get this error :

> >      ----- The following addresses had permanent fatal errors -----

> >      (reason: 403 4.7.0 TLS handshake failed.)

> >      ----- Transcript of session follows -----

> > handshake failed.
> >   Message could not be delivered for 1 day
> >   Message will be deleted from queue

> > Someone tells me that it is a STARTTLS related problem.
> > What can I check on my server SBS2000 (Exchange 2000 SP2) to find out
the
> > cause ?

 
 
 

1. TLS HANDSHAKE ERRORS. HELP!

I have a client with Exchange 2000.  When he receives mail from certain
sources, the mail bounces with a TLS handshake error message.  The TLS box
on his server is NOT checked yet when you telent to the Exchange box and do
a EHLO it says TLS enabled (from what I am told).

If I send mail from my ATT, Yahoo, MSN, no problems, he receives my mail.
If I send him mail through my company mail server (linux box) we see that
our linux server is issuing a STARTTLS command and when the Exchange Box
sees that it disconnects.  I want to make sure TLS is 100% NOT running on
that Exchange Box.

Can someone help me with where I need to check (all places) to make sure
this is not enabled.  I do not see a reason why TLS is needed and this is
only an issue with some people, not all.  Seems that this is definitely on
his end as we all receive mail from the servers without issue.

Thanks!

Jay

2. Microsoft Enginerss Help - Inetinfo eats RAM

3. Handshakes OK then times out

4. cannot send mail to Exchange 5.5 site and vice-versa!

5. TLS issue about Exchange 5.5

6. HIPAA and Exchange

7. TLS and Active Directory certificate store

8. OWA & POP3 Setup

9. Exchange 2000, TLS and Outlook 2000

10. TLS question

11. TLS & Exchange 2000

12. How to remove TLS for incoming SMTP connections