Outlook Web Access - Public Folder Problems

Outlook Web Access - Public Folder Problems

Post by Paul Berisof » Thu, 30 Nov 2000 04:00:00



I am having a problem where when I try and access the Public Folders that are
Calendars, that it displays the calendar of the user logged in, not the public
folder calendar.  Can anyone give me an idea as to why this might happen, and if
there is a solution??

I am also having a second problem where when I have selected the Public Folders
and then choose one of the folders, when I try and click on the Public Folders
icon on the left to back to select a different folder I get a runtime error:

A runtime error has occurred.
Do you wish to debug?
Line: 46
Error: 'MF.command_fr' is not an object

My options at this point are yes or no.  Any ideas??

 
 
 

Outlook Web Access - Public Folder Problems

Post by Rich Matheisen [MVP » Thu, 30 Nov 2000 04:00:00



>I am having a problem where when I try and access the Public Folders that are
>Calendars, that it displays the calendar of the user logged in, not the public
>folder calendar.  Can anyone give me an idea as to why this might happen, and if
>there is a solution??

Exchange 5.5 OWA does not support Calendar items in public folders.
The solution is to install Exchange 2000 (which will give you a new
set of problems).

Quote:>I am also having a second problem where when I have selected the Public Folders
>and then choose one of the folders, when I try and click on the Public Folders
>icon on the left to back to select a different folder I get a runtime error:

>A runtime error has occurred.
>Do you wish to debug?
>Line: 46
>Error: 'MF.command_fr' is not an object

>My options at this point are yes or no.  Any ideas??

If you're a programmer, you could examine the ASP source and fix the
error. If it's unmodified ASP, as delivered in SP3 or SP4, you can
call Microsoft and report the bug.

------------------
Rich Matheisen
MCSE+I, Exchange MVP
MS Exchange FAQ at http://www.swinc.com/resource/exch_faq.htm

 
 
 

1. Exchange 2000 Outlook Web Access Public Folders problems.

I have recently setup E2k and enable SSL by generating my own certificate,
several problems have come up, as follows:

1. On the PC's since the Public Folder scripts use the servers UNC name and
not the FQDN the certificate shows as invalid and returns an error. However
when using a wildcard cert. (*.microsoft.com) doesn't work either because it
returns the error, "The certificate authority is invalid or incorrect
12045". So the only way to get it working is to generate a certificate using
the FQDN and enter only the UNC name in the browser to access the server
(i.e.. https://server/exchange), which won't work across the internet at
all.

2. Using IE 5 on the Macintosh machines, there is no way to import the
certificate setup on the server as a valid root certificate authority, so it
is impossible to establish a correctly encrypted session without purchasing
a certificate.

Am I completely in the dark about how to do this correctly or are these some
serious bugs? I have tried to import our Apache key, but it doesn't include
the Private Key pair and Thawte told me the Cert. wouldn't work with IIS 5.0
because it doesn't recognize wild cards (*.microsoft.com). I have been at a
serious loss to find any decent documentation about how to setup ssl
correctly for Outlook Web Access on E2k. Can anyone answer my questions or
point me in the right direction?

2. Active Server Add-Ons

3. When email ends in a period like this . or ...

4. Outlook Web Access/Public Folders/Calendars Problem

5. Mail forwarding without using Out of Office

6. How to disable Public Folder Access from Outlook Web Access

7. is mapi thread safe ?

8. Anon access public folders from outlook web access?

9. Outlook Web Access - Multiple Public Folder Access

10. accessing public folders through outlook web access through the Internet

11. Accessing an Appointment Public Folder using Outlook Web access

12. Outlook Web Access - Cannot open a calendar public folder