can't start mailbox store (after restore)

can't start mailbox store (after restore)

Post by Bill » Sat, 08 Jun 2002 10:20:13



We have an MS Exchange 2K running on MS 2K.  It crashed
yesterday with a system drive failure.  When trying to
run a restore operation of the database the mainbox store
fails to start.  Tried restoring and wiping logs
starting, failed.  Trying restoring DB and logs, failed.  
Tried wiping DB, logs, starting, wiping newly created
logs, restore again, wiping logs, failed.  Any ideas
would be appreciated?  Thanks!
 
 
 

can't start mailbox store (after restore)

Post by Ronen Gabba » Sat, 08 Jun 2002 16:33:03


Hi

When restoring Exchange you need to restore the stores and logs.
You need to use an Exchange agent ( Backup program that support
Exchange not files backup )
You need to mark the "Last backup set" box during restore or the store
will no mount. (in this case you must do hard recovery eseutil /cc)
The database should be marked "this database can be overridden by restore"
on the database  properties page in the Exchange system manager.

I hope that helps.
--
Please do not send email directly to this alias.

This posting is provided "AS IS" with no warranties, and confers no rights

Ronen Gabbay   MCT   MCSE+I   MCDBA
Hi-Tech College
ISRAEL


Quote:> We have an MS Exchange 2K running on MS 2K.  It crashed
> yesterday with a system drive failure.  When trying to
> run a restore operation of the database the mainbox store
> fails to start.  Tried restoring and wiping logs
> starting, failed.  Trying restoring DB and logs, failed.
> Tried wiping DB, logs, starting, wiping newly created
> logs, restore again, wiping logs, failed.  Any ideas
> would be appreciated?  Thanks!


 
 
 

1. single mailbox restore - restored IS won't start

Production server is NT 4.0 SP6a.  Recovery server is W2K server SP4.
Exchange 5.5 SP4 on both.  I restored the IS using Veritas Backup Exec 8.6.
It appeared to restore successfully.  When I try to start it prior to
running ESEUTIL, it fails and I get the following errors in my application
event log:

Event Type: Error
Event Source: MSExchangeIS
Event Category: Recovery
Event ID: 1081
Date:  17/10/2003
Time:  12:59:48 PM
User:  N/A
Computer: EXBACK
Description:
Unable to recover the database because error 0xfffffbfa occurred after a
restore operation.

Event Type: Error
Event Source: MSExchangeIS
Event Category: General
Event ID: 5000
Date:  17/10/2003
Time:  12:59:48 PM
User:  N/A
Computer: EXBACK
Description:
Unable to initialize the Microsoft Exchange Information Store service. Error
0xfffffbfa.

I also see this:

Event Type: Error
Event Source: ESE97
Event Category: Table/Column/Index Definition
Event ID: 177
Date:  17/10/2003
Time:  12:33:18 PM
User:  N/A
Computer: EXBACK
Description:
MSExchangeIS (1368) Database 'E:\exchsrvr\MDBDATA\PRIV.EDB': The secondary
index '*T668f+Q6749+S3001+Q6748 409' of table 'Folders' is corrupt. Please
defragment the database to rebuild the index.

and these:

Event Type: Information
Event Source: ESE97
Event Category: Logging/Recovery
Event ID: 110
Date:  17/10/2003
Time:  12:33:17 PM
User:  N/A
Computer: EXBACK
Description:
MSExchangeIS (1368) The database engine has successfully completed recovery
steps.

Event Type: Information
Event Source: ESE97
Event Category: Table/Column/Index Definition
Event ID: 172
Date:  17/10/2003
Time:  12:33:18 PM
User:  N/A
Computer: EXBACK
Description:
MSExchangeIS (1368) The database engine is initiating index cleanup of
database 'E:\exchsrvr\MDBDATA\PRIV.EDB' as a result of an NT version upgrade
from 4.0.1381 SP6 to 5.0.2195 SP4.

Thes last two almost make it look as if I wait I might be ok, as it appears
as if it's getting it's ducks in a row recognizing the version difference in
Windows.  I found the KB article that discusses my errors (
http://support.microsoft.com/default.aspx?scid=kb;en-us;224977&Produc... ),
but it says in so many words that in order to fix the problem of my
Information Store not starting, I first need to start my Information
Store?????????????????  Not really helpful.

Anyone else been here and can help?  It would be much appreciated.

Thanks,

Phil

2. 8bitmime not supported

3. Information Store Hangs while 'starting'

4. Send info in Exchange Folder to SQL Server database!!!

5. Information Store Service Hangs while 'starting'

6. Dr Watson Exchange Error

7. Mailbox limit canned message

8. message concerning router from event viewer

9. Restore - cant start information store

10. ES55 Information Store does not start auf a restore of an online Backup

11. Restoring Exchange offline - cannot start information store

12. Information Store doesn;t start after Offline restore