Urgent help Need: Exchange Gateway

Urgent help Need: Exchange Gateway

Post by Rohit Sehga » Sat, 20 Nov 1999 04:00:00



Hi,

We have written Custom Exchange Gateway modifying Sample Gateway
application that comes with Exchange SDk kit.

The problem is it works well as long as we are talking about one
Exchange Server.
If we have more than One exchange server either in one site or in
multiple site. It fails to work.

My Sample MAPI program or Microsoft OutLook works fine. The diffrence
betweeen them and Our Gateway is that our Gateway has message envelope
too.

For Example :

We have 2 Exchange Servers in one Site. Say ServerA and ServerB.
ServerA has UserA and ServerB has userB. Since it's one one site, Global
directory gets synchronized.
Our gateway is installed on Server A.

If external message come to our gateway at Exchange ServerA ( for userA
and userB). We create MAPI message with Envelope for that.
We could resolve successfully both userA and userB to their Exchange
addresses in Gateway.
When we submit the message it only goes to userA and NDR is generated
for UserB.
I don't know why??!!

Message is fine. Both recipient get resolved to their corresponding
exchange users.
Also the message that userA receives, If I Send reply to All, then It
goes fine to user B as it does not go through over gateway.

Any Help appreciated.

thanks

Rohit

 
 
 

1. Urgent help Need: Exchange Gateway

Hi,

We have written Custom Exchange Gateway modifying Sample Gateway
application that comes with Exchange SDk kit.

The problem is it works well as long as we are talking about one
Exchange Server.
If we have more than One exchange server either in one site or in
multiple site. It fails to work.

My Sample MAPI program or Microsoft OutLook works fine. The diffrence
betweeen them and Our Gateway is that our Gateway has message envelope
too.

For Example :

We have 2 Exchange Servers in one Site. Say ServerA and ServerB.
ServerA has UserA and ServerB has userB. Since it's one one site, Global
directory gets synchronized.
Our gateway is installed on Server A.

If external message come to our gateway at Exchange ServerA ( for userA
and userB). We create MAPI message with Envelope for that.
We could resolve successfully both userA and userB to their Exchange
addresses in Gateway.
When we submit the message it only goes to userA and NDR is generated
for UserB.
I don't know why??!!

Message is fine. Both recipient get resolved to their corresponding
exchange users.
Also the message that userA receives, If I Send reply to All, then It
goes fine to user B as it does not go through over gateway.

Any Help appreciated.

thanks

Rohit

2. Deliver mail using DNS; Exchange 5 behind MSProxy

3. Urgent.......Help Needed...Urgent.......Help Needed...Urgent.......Help Needed...

4. Acceptance of Mail in Domain literal Format help!!!!

5. evnet ID 4083 urgent, urgent, urgent......help, help....very urgent

6. Upgrade question.

7. URGENT Installing OWA in a different site then localhost URGENT help needed

8. Multiple POP3 accounts with Single ISP mailbox ?

9. URGENT HELP NEEDED after MS mail migration to Exchange 5.5

10. ETRN: connecting exchange through etrn HELP NEEDED URGENT