Error Msg: You do not have permission to log on

Error Msg: You do not have permission to log on

Post by msnews.microsoft.co » Fri, 07 May 1999 04:00:00



when running the below script, i get the permissions error when connecting
to the Inbox.  The printing of the CurrentUser works ok.

any ideas??

strProfileInfo= "mailserver" & vbLF & "mailbox"
Set objSession= CreateObject("MAPI.Session")
objSession.Logon "", "", False, True, 0, True, strProfileInfo
Response.write objSession.CurrentUser
Set objFolder = objSession.Inbox
Set objMessages = objFolder.Messages
.
.
.

 
 
 

Error Msg: You do not have permission to log on

Post by Siegfried Webe » Sun, 09 May 1999 04:00:00


I've seen a knowledge base articles talking about that (can't recall, sorry). Off the top of my head, it seems to be by design that a successful CDO logon does not make sure to have the correct permissions. You need to open a folder to check if everything went well.

--
</Siegfried>


>when running the below script, i get the permissions error when connecting
>to the Inbox.  The printing of the CurrentUser works ok.

>any ideas??

>strProfileInfo= "mailserver" & vbLF & "mailbox"
>Set objSession= CreateObject("MAPI.Session")
>objSession.Logon "", "", False, True, 0, True, strProfileInfo
>Response.write objSession.CurrentUser
>Set objFolder = objSession.Inbox
>Set objMessages = objFolder.Messages
>.
>.
>.


 
 
 

1. After migration, Error: You do not have permission to log on

After migrating a user with the Exchange Migration Wizard (from MS Mail
for AppleTalk Networks) and linking this migrated Exchange account to an
NT account, we get the error "Unable to open default email folders:  you
do not have permission to log on."  when we attempt to log in for the
first time.  We get this error when we log in from the Outlook 98 client
on an NT 4.0 computer.  We also get the error when running the latest
Outlook for Mac (8.1) client).  Finally, we are unable to connect using
Outlook Web Access (OWA).

This is not the first time we've migrated an account to Exchange.  In
the past, we've seen the same error when attempting to log in for the
first time (after migration) from Outlook 98, but when we then log in
from a Mac, it works.  Sometimes it fails first on the Mac, then works
from NT.  In any case, after one failure, it seems to work okay.  Today
is the first time we've been completely shut out of the newly-migrated
account.

Do any of you know why we get this permission error after migration?

Thanks!

Mike Castle

2. Exchange 5.5 Standard to Enterprise upgrade (reinstall) error

3. Err Msg: Originator does not have permission

4. Directory Synchronization fails to start

5. Error msg when logging off of OWA

6. !!!

7. Event Log error msg

8. Permissions on specific mailbox

9. Exchange log on error msg...

10. The body of the msg comes up with error msg

11. Event ID 9405 Msg logged in event Viewer App Log

12. replication not done???no error

13. *.msg.msg or *.msg attachments