FTP Access problem: directory listing doesn't work, but downloading works.

FTP Access problem: directory listing doesn't work, but downloading works.

Post by Zo Crate » Tue, 25 Mar 2003 08:01:17



I have a perplexing FTP problem.

I have two PCs networked and running the FTP server on PC1 and trying
to access it from FTP client on PC2.  Connection, authentication,
uploading, and downloading all work fine, but listing (of directory)
doesn't work. Here's my hardware environment:

Both PCs: running Windows 2000 Prof SP3, with administrator privilege.
FTP Server: tried several, Serv-u, WS FTP... the user was configured
to have every rights.
FTP Client: CuteFtp, FtpExplorer, FtpVoyage
Networked with Linksys firewall/router which connects to DSL modem.

All FTP clients work fine with connection and authentication, but have
trouble with initial directory listing.  Since both server and client
are within the same firewall and 192.168.1.x is used as IP, I suppose
I can eliminate the factors such as opening/forwarding of ports or
using passive mode.

All other TCP apps work fine also -- web server, Windows network,
email, news.

As a last resort I used DOS FTP client to see what was going on.
Here's the result:

===========================
ftp> open 192.168.1.31
Connected to 192.168.1.31.
220 Serv-U FTP Server v4.1 for WinSock ready...
User (192.168.1.31:(none)): testuser
331 User name okay, need password.
Password:
230 User logged in, proceed.
ftp> dir
200 PORT Command successful.
150 Opening ASCII mode data connection for /bin/ls.
----------   1 user     group           0 Mar  3 12:52 AUTOEXEC.BAT
drw-rw-rw-   1 user     group           0 Mar 19 22:03 App
226 Transfer complete.
ftp: 129 bytes received in 60.09Seconds 0.00Kbytes/sec.
ftp> get "ftp.log"
200 PORT Command successful.
150 Opening ASCII mode data connection for ftp.log (44224690 bytes).
226 Transfer complete.
ftp: 44224690 bytes received in 5.50Seconds 8043.78Kbytes/sec.
===========================

As is shown above, even downloading works fine.  The response to the
dir is cut off after the second line and timed out after 60 seconds
with only 129 bytes received. This was why all FTP clients showed
nothing on initial directory.

I'd appreciate any help.

TIA
Zo.

 
 
 

1. IP-Works FTP doesn't work

Hi all,
I'm trying to send a file to a ftp server using Dev-Soft FTP control. After
sending the file the dll goes to a receive
state and doesn't return the control to application. I've tried with the
last version 4.0 and with a NEC MobilePro 800, HP Jornada 430 and a
Cassiopeia E-15. All of them with the same error. I have tried with the VBCE
control version with the same result. Anybody has tried the library ?

Fabian

2. 95' desktop

3. Ip-Works FTP doesn't work

4. MCE messing up show recordings

5. FTP doesn't work in IE but works great in Navigator?

6. wine 980413 no icons in progman

7. ftp downloading doesn't work through IE

8. Procomm Plus like app for NT 4.0?

9. ftp Hotfix - ftp download won't work

10. Problem with download link-doesn't work

11. Don't download message rule doesn't work

12. FTP doesn't work!

13. FTP doesn't work