PB2.12

PB2.12

Post by Panhuber Astri » Thu, 29 Jul 1999 04:00:00



Hi!

I have created a new project in PB 2.12 (devcon-version) and now I want to
compile it. Using the command-line option (DOS-Window as in ETK), I can
compile it.

But when I use in PB any item from the Build-menu, I get the error-message
"Unable to initialize the build environment..."

Does anyone have the same problem? Has anyone solved it?????

Please help!

Astrid

 
 
 

PB2.12

Post by Christian M. Nette » Thu, 29 Jul 1999 04:00:00


FYI:
I have two copies of it installed. On one machine, it works just fine and on
the
other I have exactly the same problem.

On the machine it doesn't work on, I also have the CE 3.0 Preview installed,
which sort of comes with the PB 2.11 ide. Maybe that's the problem.
I have pretty much narrowed it down to a path problem. It seems it can't
find
some batch files, because the path isn't setup right.

If you find out what's wrong in your setup, let me know.

Christian M. Netter
Assistant Research Engineer
United Technologies Research Center
411 Silver Lane, M/S 129-55
East Hartford, CT. 06108

Phone:  (860)-610-7758
Fax:    (860)-610-7494


Quote:>Hi!

>I have created a new project in PB 2.12 (devcon-version) and now I want to
>compile it. Using the command-line option (DOS-Window as in ETK), I can
>compile it.

>But when I use in PB any item from the Build-menu, I get the error-message
>"Unable to initialize the build environment..."

>Does anyone have the same problem? Has anyone solved it?????

>Please help!

>Astrid


 
 
 

PB2.12

Post by Ken Le » Thu, 29 Jul 1999 04:00:00


Is it ok to have 2.11 and 2.12 on the same NT machine?



> FYI:
> I have two copies of it installed. On one machine, it works just fine and
on
> the
> other I have exactly the same problem.

> On the machine it doesn't work on, I also have the CE 3.0 Preview
installed,
> which sort of comes with the PB 2.11 ide. Maybe that's the problem.
> I have pretty much narrowed it down to a path problem. It seems it can't
> find
> some batch files, because the path isn't setup right.

> If you find out what's wrong in your setup, let me know.

> Christian M. Netter
> Assistant Research Engineer
> United Technologies Research Center
> 411 Silver Lane, M/S 129-55
> East Hartford, CT. 06108

> Phone:  (860)-610-7758
> Fax:    (860)-610-7494



> >Hi!

> >I have created a new project in PB 2.12 (devcon-version) and now I want
to
> >compile it. Using the command-line option (DOS-Window as in ETK), I can
> >compile it.

> >But when I use in PB any item from the Build-menu, I get the
error-message
> >"Unable to initialize the build environment..."

> >Does anyone have the same problem? Has anyone solved it?????

> >Please help!

> >Astrid

 
 
 

PB2.12

Post by mark » Thu, 29 Jul 1999 04:00:00



> Is it ok to have 2.11 and 2.12 on the same NT machine?



> > FYI:
> > I have two copies of it installed. On one machine, it works just fine and
> on
> > the
> > other I have exactly the same problem.

> > On the machine it doesn't work on, I also have the CE 3.0 Preview
> installed,
> > which sort of comes with the PB 2.11 ide. Maybe that's the problem.
> > I have pretty much narrowed it down to a path problem. It seems it can't
> > find
> > some batch files, because the path isn't setup right.

> > If you find out what's wrong in your setup, let me know.

> > Christian M. Netter
> > Assistant Research Engineer
> > United Technologies Research Center
> > 411 Silver Lane, M/S 129-55
> > East Hartford, CT. 06108

> > Phone:  (860)-610-7758
> > Fax:    (860)-610-7494



> > >Hi!

> > >I have created a new project in PB 2.12 (devcon-version) and now I want
> to
> > >compile it. Using the command-line option (DOS-Window as in ETK), I can
> > >compile it.

> > >But when I use in PB any item from the Build-menu, I get the
> error-message
> > >"Unable to initialize the build environment..."

> > >Does anyone have the same problem? Has anyone solved it?????

> > >Please help!

> > >Astrid

I would not run different versions on the same machine - that is asking
for trouble.  I heard somebody say that you had to manually set some
defines in the PB 2.12 environment, like _FLATRELEASEDIR etc.
--
 Running Linux Kernel 2.2.5
 Fight broadband monopolies - www.opennetcoalition.org
 
 
 

PB2.12

Post by Pedro R » Fri, 30 Jul 1999 04:00:00


I have PB2.12 and PB2.11 installed on the same machine. Since I installed PB
2.12 last, the system environment variable are now set for 2.12. Whenever I
wnat to build 2.11 I have to go into "System" under "Control Panel" and
change the following variables:
_FLATRELEASEDIR and _WINCEROOT.
    Once these variables reflect 2.11, one can build 2.11 code again.

Pedro.


> > Is it ok to have 2.11 and 2.12 on the same NT machine?



> > > FYI:
> > > I have two copies of it installed. On one machine, it works just fine
and
> > on
> > > the
> > > other I have exactly the same problem.

> > > On the machine it doesn't work on, I also have the CE 3.0 Preview
> > installed,
> > > which sort of comes with the PB 2.11 ide. Maybe that's the problem.
> > > I have pretty much narrowed it down to a path problem. It seems it
can't
> > > find
> > > some batch files, because the path isn't setup right.

> > > If you find out what's wrong in your setup, let me know.

> > > Christian M. Netter
> > > Assistant Research Engineer
> > > United Technologies Research Center
> > > 411 Silver Lane, M/S 129-55
> > > East Hartford, CT. 06108

> > > Phone:  (860)-610-7758
> > > Fax:    (860)-610-7494



> > > >Hi!

> > > >I have created a new project in PB 2.12 (devcon-version) and now I
want
> > to
> > > >compile it. Using the command-line option (DOS-Window as in ETK), I
can
> > > >compile it.

> > > >But when I use in PB any item from the Build-menu, I get the
> > error-message
> > > >"Unable to initialize the build environment..."

> > > >Does anyone have the same problem? Has anyone solved it?????

> > > >Please help!

> > > >Astrid

> I would not run different versions on the same machine - that is asking
> for trouble.  I heard somebody say that you had to manually set some
> defines in the PB 2.12 environment, like _FLATRELEASEDIR etc.
> --
>  Running Linux Kernel 2.2.5
>  Fight broadband monopolies - www.opennetcoalition.org

 
 
 

PB2.12

Post by Panhuber Astri » Wed, 04 Aug 1999 04:00:00


Hi!

Thanks for your answers. On my PC the ETK was installed. After reading your
mails I thought, this could be the problem. So I bought a new PC and
installed:
- Windows NT4.0
- CE Services 2.0
- SP3 f. NT4.0
- PB 2.12

But the problem is still there!!!!!

I found out, that it has something to do with my Platform. If I create a
project, depending on the ODO-BSP, I can compile it. But I have to create a
project for my self-designed HW.
This HW already works under CE 2.0. So I copied the TimbaTec-Directory
(where TimbaTec is my HW) from the wince20\platform-directory to the
wince212\platform-directory.
Then I created a new project named TimbaTec. When the Wizard asks for the
BSP, I did not select one. The wizard warns me, but sayed I can continue. In
the Project-Parameters under Hardware Specific Files, I can see the
Config.bib and Platfrom.reg, -.bib, -.dat and -.db-Files. This files are
located in my platform\TimbaTec-directory, so I thought, PB know, that my
project is based on this platform. But when I want to <Build Platform>, I
get the error-message "Unable to initialize the build environment..."

What did I worng? Whow can I create my own BSP?
Can anyone please help me?

Astrid


|I have PB2.12 and PB2.11 installed on the same machine. Since I installed
PB
|2.12 last, the system environment variable are now set for 2.12. Whenever I
|wnat to build 2.11 I have to go into "System" under "Control Panel" and
|change the following variables:
|_FLATRELEASEDIR and _WINCEROOT.
|    Once these variables reflect 2.11, one can build 2.11 code again.
|
|Pedro.

|> >
|> > Is it ok to have 2.11 and 2.12 on the same NT machine?
|> >


|> > > FYI:
|> > > I have two copies of it installed. On one machine, it works just fine
|and
|> > on
|> > > the
|> > > other I have exactly the same problem.
|> > >
|> > > On the machine it doesn't work on, I also have the CE 3.0 Preview
|> > installed,
|> > > which sort of comes with the PB 2.11 ide. Maybe that's the problem.
|> > > I have pretty much narrowed it down to a path problem. It seems it
|can't
|> > > find
|> > > some batch files, because the path isn't setup right.
|> > >
|> > > If you find out what's wrong in your setup, let me know.
|> > >
|> > > Christian M. Netter
|> > > Assistant Research Engineer
|> > > United Technologies Research Center
|> > > 411 Silver Lane, M/S 129-55
|> > > East Hartford, CT. 06108

|> > > Phone:  (860)-610-7758
|> > > Fax:    (860)-610-7494
|> > >
|> > >


|> > > >Hi!
|> > > >
|> > > >I have created a new project in PB 2.12 (devcon-version) and now I
|want
|> > to
|> > > >compile it. Using the command-line option (DOS-Window as in ETK), I
|can
|> > > >compile it.
|> > > >
|> > > >But when I use in PB any item from the Build-menu, I get the
|> > error-message
|> > > >"Unable to initialize the build environment..."
|> > > >
|> > > >Does anyone have the same problem? Has anyone solved it?????
|> > > >
|> > > >
|> > > >Please help!
|> > > >
|> > > >Astrid
|> > > >
|> > > >
|> > > >
|> > > >
|> > >
|> > >
|> I would not run different versions on the same machine - that is asking
|> for trouble.  I heard somebody say that you had to manually set some
|> defines in the PB 2.12 environment, like _FLATRELEASEDIR etc.
|> --
|>  Running Linux Kernel 2.2.5
|>  Fight broadband monopolies - www.opennetcoalition.org
|
|

 
 
 

1. how to mobe PB2.11 projects to PB2.12 under IDE env ?

Hi,
    I had a project which can be built under PB2.11 with the blddemo
command. How can move the project to PB2.12 and compile it under IDE
environment ? Is there any related document to describe this or tell me how
to make a CEC file ?

Arthur

2. how to change the color depth?

3. TARGETTYPE & PB2.12

4. I don't think I have my e-mail account in Outlook set up right

5. Problem build CEPC+MAXALL+PPC using PB2.12

6. Video Install

7. buildrel or makeimg in PB2.12 IDE

8. CScrollView Does Not Work

9. MFC app in PB2.12

10. DESCRIPTION-Statement (PB2.12)

11. DHCP +PB2.12 +CEPC

12. Converting PB2.12 workspaces to 3.0

13. PB2.12 & Kernel debugger