XP RPC service starting and never starts, nothing else works computer slow help!

XP RPC service starting and never starts, nothing else works computer slow help!

Post by Kevin Smi » Fri, 01 Nov 2002 22:46:13



When booting my computer into XP pro, it takes forever.  Network
devices and various other things don't start.  Went to services and
discovered that the RPC service just stays starting and never starts.
I cannot even get into any logs to see what the problem is nor make it
stop to try to start it manually.  Is there a procedure to stop the
service while its starting?  I've let it sit for more than an hour
hoping it would error out or something.  I've read that Notron 2003
can be a problem but I cannot uninstall it because RPC won't start
therefore the windows installer service won't either.  Can't seem to
get into or find system restore either.  Any other suggestions to work
around this.  It boots into safe mode OK, and also into win98 OK.  I
really don't wanna reinstall, is this my only hope?  Where is the
proper log file for finding why the service won't start, like I said
it never errors out just 'starting'.

thanks in advance for any help!

 
 
 

XP RPC service starting and never starts, nothing else works computer slow help!

Post by eXPonen » Fri, 01 Nov 2002 23:54:42


Have you tried a Windows repair by booting from you CD, or even sfc/ scannow
from the command prompt [you'll be prompted for your XP CD for this]. Either
one of these methods should not affect how you have you machine setup, but
should moreover repair, if that is what is required, the RPC service.
It used to be that you could uninstall using NAVs uninstaller, but as you
say I believe that Symantec now use the Windows installer.
One way or the other somthing needs to change. [do nothing and nothing will
be done]
Good luck


Quote:> When booting my computer into XP pro, it takes forever.  Network
> devices and various other things don't start.  Went to services and
> discovered that the RPC service just stays starting and never starts.
> I cannot even get into any logs to see what the problem is nor make it
> stop to try to start it manually.  Is there a procedure to stop the
> service while its starting?  I've let it sit for more than an hour
> hoping it would error out or something.  I've read that Notron 2003
> can be a problem but I cannot uninstall it because RPC won't start
> therefore the windows installer service won't either.  Can't seem to
> get into or find system restore either.  Any other suggestions to work
> around this.  It boots into safe mode OK, and also into win98 OK.  I
> really don't wanna reinstall, is this my only hope?  Where is the
> proper log file for finding why the service won't start, like I said
> it never errors out just 'starting'.

> thanks in advance for any help!