Windows XP, Multiple User Accounts, Multiple NIC, managing routes on startup

Windows XP, Multiple User Accounts, Multiple NIC, managing routes on startup

Post by Michael McKnigh » Sun, 10 Mar 2002 12:58:25



I am trying to find a way to manage the NICs that I have with a batch
file that runs on startup.  I am not sure of the correct way to do
this under XP.  I need to delete a default route for one of the NIC
cards as it is for a private internal network and keep the default
route for the NIC card used to access the Internet.

I can manage the necessary route commands to delete the route and have
set up some perisistent routes for the private network.  However, I am
just not sure where to place the .bat file I have created so that it
runs when the computer starts up before any of the users log in.  I
need to have this run all the time prior to anyone logging in so the
routes are set.

I have tried placing this in all start up folders but this just
doesn't do what I want and it can't be run by some of the users anyway
because of permissions.

Any help would be greatly appreciated.  I have scanned the newsgroups
and have not seen this issue.  Any other ideas about how to do this
differently would be appreciated as well.  Thanks.

Mike

 
 
 

1. Windows XP, Multiple User Accounts, Multiple NIC, managing routes on startup

I am trying to find a way to manage the NICs that I have with a batch
file that runs on startup.  I am not sure of the correct way to do
this under XP.  I need to delete a default route for one of the NIC
cards as it is for a private internal network and keep the default
route for the NIC card used to access the Internet.

I can manage the necessary route commands to delete the route and have
set up some perisistent routes for the private network.  However, I am
just nor sure where to place the .bat file I have created so that it
runs when the computer starts up before any of the users log in.  I
need to have this run all the time prior to anyone logging in so the
routes are set.

I have tried placing this in all start up folders but this just
doesn't do what I want and it can't be run by some of the users anyway
because of permissions.

Any help would be greatly appreciated.  I have scanned the newsgroups
and have not seen this issue.  Any other ideas about how to do this
differently would be appreciated as well.  Thanks.

Mike

2. Distorted sound and screen

3. New article on OE multiple addresses, multiple Identities and multiple User Accounts

4. TIFF JPEG Preview

5. No Startup Sounds Play with Multiple User Accounts in XP

6. XP PRO w/IBM Microdrive

7. The Logon or Startup Sound May Not Play with Multiple User Accounts in Windows X

8. Change View in My Videos page

9. Multiple users and multiple Outlook accounts

10. Managing multiple OE6 accounts in XP Home

11. IP Routing on multiple NIC system (XP-Pro)

12. Windows XP: Using multiple Novell users to loginto one Windows XP User

13. managing OE in XP Home with multiple users