Samba Performance Problem with HPUX11 and pwrite

Samba Performance Problem with HPUX11 and pwrite

Post by Don Hiscoc » Sun, 05 Jan 2003 05:46:47



We're running samba 2.7a on hpux11i. Since HPUX added pread/pwrite
(PHKL_20349), performance is noticeably degraded copying serveral small
files to a share. For example, copying a folder from my local drive, 250mb
total, 265 files, 10bt to a samba share takes 95 seconds. If I edit config.
cache, change ac_cv_func_pwrite, ac_cv_func_pwrite64 to no, reconfig and
recompile, the copy only takes 35 seconds. The ratio is even higher accross
a faster link.

Anyone else experience this? I guess my next step is to pursue this with HP.

 
 
 

Samba Performance Problem with HPUX11 and pwrite

Post by Rick Jone » Sun, 05 Jan 2003 06:18:13



Quote:> We're running samba 2.7a on hpux11i. Since HPUX added pread/pwrite
> (PHKL_20349)

Are you running 11i, or 11.0? PHKL_20349 is an HP-UX 11.0 patch, not
an HP-UX 11i (11.11) patch.

Quote:> small files to a share. For example, copying a folder from my local
> drive, 250mb total, 265 files, 10bt to a samba share takes 95
> seconds. If I edit config.  cache, change ac_cv_func_pwrite,
> ac_cv_func_pwrite64 to no, reconfig and recompile, the copy only
> takes 35 seconds. The ratio is even higher accross a faster link.

Does the disc access look different on the server between the two
configs?

rick jones
--
these opinions are mine, all mine; HP might not want them anyway... :)
feel free to post, OR email to raj in cup.hp.com  but NOT BOTH...

 
 
 

Samba Performance Problem with HPUX11 and pwrite

Post by Don Hiscoc » Sun, 05 Jan 2003 07:08:52


We are running bot 11 and 11i. And yes it's true PHKL_20349 is a 11.0 patch.
Base 11i already supports pread/pwrite (for what its worth).



> > We're running samba 2.7a on hpux11i. Since HPUX added pread/pwrite
> > (PHKL_20349)

> Are you running 11i, or 11.0? PHKL_20349 is an HP-UX 11.0 patch, not
> an HP-UX 11i (11.11) patch.

> > small files to a share. For example, copying a folder from my local
> > drive, 250mb total, 265 files, 10bt to a samba share takes 95
> > seconds. If I edit config.  cache, change ac_cv_func_pwrite,
> > ac_cv_func_pwrite64 to no, reconfig and recompile, the copy only
> > takes 35 seconds. The ratio is even higher accross a faster link.

> Does the disc access look different on the server between the two
> configs?

> rick jones
> --
> these opinions are mine, all mine; HP might not want them anyway... :)
> feel free to post, OR email to raj in cup.hp.com  but NOT BOTH...

 
 
 

1. Performance problem with HPUX11.00

Hi,

We have recently upgraded Our D230 running HPUX-10.20 to a D390
running HPUX-11.00. This is Our primary mail server and the reason
for the upgrade was to get a better perfomance. At the same time we
upgraded sendmail to the newest version 8.9.3. Prior to that we
ran the 8.8.6. version.

We have performance problems on the new machine , which shows as a
load increasing from 0 upto 60. Hp has suggested to use Glance to
track down the problem. This shows a lot of diskactivity on the /var
file system , and we can't figure out where this comes from. The
mail spool is located on a different filesystem.

Has anyone discovered similar problems with the HPUX-11 version?

--

2. How to derive a class from special classes

3. Samba on HP-UX performance problem

4. Reinstalling windows errors

5. samba and hpux11

6. Blue screen of death

7. pread() & pwrite()

8. System Accounting

9. serial problem with dtcmgr ocd printer on hpux11.00

10. Java UI problems with NT to HPUX11 port

11. solaris6/hpux11 nfs problem ?

12. URGENT:SIGSEGV problem with jre12204(HPUX11.0)

13. Samba and Pro Engineer problems..