eshell doesn't show error messages

eshell doesn't show error messages

Post by Alexander Vorobi » Wed, 29 Aug 2001 08:15:52



Hi,

My problem is that eshell doesn't show error messages from external
programs
such as tar, less etc. It just displays command prompt again on the
next line. Embedded commands (ls & Co) do show erros ok.

When I try M-x eshell-test it opens up a buffer named *eshell test*
containing the following:

Testing Eshell under GNU Emacs 21.4 (patch 3) "Academic Rigor" XEmacs
Lucid (i686-pc-linux)

--- Mon Aug 27 18:16:26 2001 --- (completed in 0 seconds)

and it displays a message "Eshell test suite completed: No failures"
in minibuffer. I use pre-packaged for xemacs eshell from xemacs.org.

My configuration is XEmacs 21.4.3 with mule on Linux (kernel 2.4.5)

Thanks in advance for any help,
Alexander

 
 
 

1. movemail program doesn't print error messages

--pgp-sign-Multipart_Mon_Mar_31_17:22:57_1997-1
Content-Type: text/plain; charset=US-ASCII

Hi!

Two lines in lib-src/movemail.c are interchanged in XEmacs 19.15,
preventing the program from printing error messages. I've appended a
patched to correct it.

Florian

*** movemail.c.old      Wed Dec 18 04:29:16 1996
--- movemail.c  Mon Mar 31 17:19:33 1997
***************
*** 375,382 ****
       CONST char *s1, *s2;
  {
    if (delete_lockname)
-   error (s1, s2, "");
      unlink (delete_lockname);
    exit (1);
  }

--- 375,382 ----
       CONST char *s1, *s2;
  {
    if (delete_lockname)
      unlink (delete_lockname);
+   error (s1, s2, "");
    exit (1);
  }

--pgp-sign-Multipart_Mon_Mar_31_17:22:57_1997-1
Content-Type: application/pgp-signature
Content-Transfer-Encoding: 7bit

-----BEGIN PGP MESSAGE-----
Version: 2.6.3i
Comment: Key at http://www1.stuttgart.netsurf.de/~fw/pgpkey.asc

iQCVAwUBMz/W2W0jFR0EEvdhAQHnggP/Z9rHVTIM5fm2Ezb4CHRRJSv0lGEHpl8P
4xNOZkdHYUyARnPow1+NyTGKRrIST3tX6WoA/LvSIiHocWxP3+RHO7xidkwzDqmg
c8PVC6KyH1pxp2waTo2pyGFlD2oHE6NH2H2WGK4nn+9kYWTNNnDs9YeisAdg/jQq
WyLH9GKAYL4=
=kwv9
-----END PGP MESSAGE-----

--pgp-sign-Multipart_Mon_Mar_31_17:22:57_1997-1--

2. SQL programming

3. Parsing lint error messages doesn't seem to work right

4. Fw: Errcode: 13 with mysqlimport

5. Speedbar doesn't show files

6. "Cannot update the database"

7. Speedbar doesn't show info nodes (21.4.4, RH 7.2)

8. WTB: A500 SCSI + RAM expansion

9. Weight item doesn't show up in the options menu

10. background color doesn't show on remote machine

11. Speedbar: Added extension doesn't show up in bar

12. wide reply in Gnus with message mode doesn't omit own address

13. in compilation, goto-error doesn't work