How to display Chinese GB and BIG5 characters in 20.4 w/ Mule?

How to display Chinese GB and BIG5 characters in 20.4 w/ Mule?

Post by David Yu » Sat, 14 Mar 1998 04:00:00



hi,

i installed the binary package of xemacs-20.4 with Mule from ftp.xemacs.org
both on linux and OSF/1 (DEC Alpha).  it displayed the FAQ-Mule.cn (in
chinese) correctly. but it won't display any gb or big5 files correctly.

when i add (load "chinese") in .emacs or in the command line:

M-x load-library RET chinese RET

it complains:

cannot redefine existing charset: chinese-cns11643-3

please someone out there tell me what i have done wrong. i believe
i have installed all required chinese fonts.

thanks,

david

--
 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
                              David Yuan
                    MCI Telecommunications Corporation
  901 International Pkwy.        ||      Office Number: 972 498 1129

 
 
 

How to display Chinese GB and BIG5 characters in 20.4 w/ Mule?

Post by Jim Da » Mon, 16 Mar 1998 04:00:00


I downloaded a precompiled version from ftp.xemacs.org for linux.
After  mule starts, under the pulldown menu "Mule", set language
environment to chinese-gb, then open any gb encoded file (cm9703b.gb, for
example). This works for me.


> hi,

> i installed the binary package of xemacs-20.4 with Mule from ftp.xemacs.org
> both on linux and OSF/1 (DEC Alpha).  it displayed the FAQ-Mule.cn (in
> chinese) correctly. but it won't display any gb or big5 files correctly.

> when i add (load "chinese") in .emacs or in the command line:

> M-x load-library RET chinese RET

> it complains:

> cannot redefine existing charset: chinese-cns11643-3

> please someone out there tell me what i have done wrong. i believe
> i have installed all required chinese fonts.

> thanks,

> david

> --
>  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
>                               David Yuan
>                     MCI Telecommunications Corporation
>   901 International Pkwy.        ||      Office Number: 972 498 1129

--
Jim Dai 404-894-9139 404-894-2301(fax) http://www.isye.gatech.edu/faculty/dai/
School of Industrial and Systems Engineering  and School of Mathematics
Georgia Institute of Technology, Atlanta, GA 30332-0205

 
 
 

1. Chinese BIG5 and mule problem

Hey ho.

I know nothing about mule, so please be gentle.

I'd like to use the Chinese BIG5 character set to read a piece of
mail, but I get the error:

(1) (font/warning) Unable to instantiate font for face default, charset chinese-big5-1

(I get the same error when I use C-h L to describe BIG5.)

So, just to see what I could do, I tried to execute
setup-chinese-big5-environment, and I get the following error:

Loading china-util...
Loading china-util...done
Lisp nesting exceeds `max-lisp-eval-depth'

I tried setting max-lisp-eval-depth to 3000 instead of 500 and still
get the error.

What is the most painless way to use the Chinese big5 character set?
Please speak slowly and use small words.  Thanks.

--
Jesse Hughes

"You see 300 of something, anything, and you go `[Man], that's a lot of
stuff.'" -- Jim Bigler, quoted in the Pittsburgh Post-Gazette.

2. Video driver install questions

3. mule/quail bug in emacs 20.4 for devanagari characters ?

4. HELP! NETWARE ADMIN

5. display of control-1 charset (XEmacs 20.4/MULE)

6. Mathematica

7. how to read big5 (chinese) code in xemacs 19.15 (W3)?

8. how do I make gnu emacs display chinese characters?

9. GNU Emacs 19.XX and Chinese Fonts GB2312 and Big5

10. xemacs -nw fail to display mule character

11. why I can't display japanese character in term using xemacs whih mule