Gnus doesn't work in Xemacs, does in Emacs

Gnus doesn't work in Xemacs, does in Emacs

Post by Scott D. Anders » Thu, 05 Jun 1997 04:00:00



I hope this is the right newsgroup; I don't know of an XEmacs & Gnus
newsgroup, but I'll redirect if someone can suggest where.

Just this week I downloaded and installed the common stuff for XEmacs
19.15 and the precompiled binaries for sparc-sun-solaris2.4.  It was
very easy, I didn't do anything weird, and everything seems to work
just fine.

However, today I tried reading news via Gnus.  It started up Gnus
v5.4.37, displayed the logo (very nice), and failed with the
minibuffer message: Cannot open load file: chat

To be sure it wasn't my fault, I ran XEmacs with the -q option to
suppress my own .emacs and got the identical behavior.

Now, we also have GNU Emacs 19.30.1 on our system, and Gnus works fine
on that (version 5.1).  In fact, that's how I'm posting this message.
Both versions of Gnus are getting the news server information from the
NNTPSERVER environment variable:

export NNTPSERVER="news.spelman.edu"

Have I messed up the installation or configuration?  How can I fix
this?  I don't mind reading news with GNU Emacs, but I like using one
integrated system.

I appreciate the help.

--
Scott D. Anderson
Spelman College, Atlanta, Georgia

http://www.spelman.edu/~anderson/
--
Scott D. Anderson
Spelman College, Atlanta, Georgia

http://www.spelman.edu/~anderson/

 
 
 

Gnus doesn't work in Xemacs, does in Emacs

Post by Steven L Bau » Thu, 05 Jun 1997 04:00:00



Quote:> I hope this is the right newsgroup; I don't know of an XEmacs & Gnus
> newsgroup, but I'll redirect if someone can suggest where.

gnu.emacs.gnus is the general newsgroup for Gnus.  There are plenty of
Gnus Groupies here too.

Quote:> Just this week I downloaded and installed the common stuff for XEmacs
> 19.15 and the precompiled binaries for sparc-sun-solaris2.4.  It was
> very easy, I didn't do anything weird, and everything seems to work
> just fine.
> However, today I tried reading news via Gnus.  It started up Gnus
> v5.4.37, displayed the logo (very nice), and failed with the
> minibuffer message: Cannot open load file: chat

This isn't referenced by any recent Gnus (it is in the final version of
GNUS4 packaged with XEmacs-19.13) and definitely not the Gnus in XEmacs
19.15.  Enable debug-on-error by selecting Options -> General Options
-> Debug on Error from the menubar, or doing
M-: (setq debug-on-error t)
and send us the lisp stack backtrace.

Quote:> To be sure it wasn't my fault, I ran XEmacs with the -q option to
> suppress my own .emacs and got the identical behavior.

O.K.  Very good.  

 ...

Quote:> Have I messed up the installation or configuration?  How can I fix
> this?  I don't mind reading news with GNU Emacs, but I like using one
> integrated system.

Poke around for a lurking installation of GNUS 4 somewhere on your
system and nuke it.
--

Unsolicited commercial e-mail will be billed at $250/message.

 
 
 

Gnus doesn't work in Xemacs, does in Emacs

Post by Hrvoje Niksi » Fri, 06 Jun 1997 04:00:00



Quote:> However, today I tried reading news via Gnus.  It started up Gnus
> v5.4.37, displayed the logo (very nice), and failed with the
> minibuffer message: Cannot open load file: chat

Gnus works fine for many XEmacs users, so it should be something at
your site.  Try setting `debug-on-error' to t before running Gnus, and

Quote:> Have I messed up the installation or configuration?  How can I fix
> this?

It should work by default.  Maybe you have something strange in your
.newsrc.eld, or in your site init file.

--

--------------------------------+--------------------------------
ED WILL NOT CORRUPT YOUR PRECIOUS BODILY FLUIDS!!

 
 
 

Gnus doesn't work in Xemacs, does in Emacs

Post by Pete War » Fri, 06 Jun 1997 04:00:00




> > To be sure it wasn't my fault, I ran XEmacs with the -q option to
> > suppress my own .emacs and got the identical behavior.
> Poke around for a lurking installation of GNUS 4 somewhere on your
> system and nuke it.

You might also have the environment variable EMACSLOADPATH set to
include an old version of GNUS -- which is why it still gets it with
xemacs -q.

--pete

 
 
 

1. dtx and ins in xemacs

Hi,

how do I make xemacs recognize dtx and ins (documented LaTeX code)
files as LaTeX or TeX file? Or is there even some special xemacs
mode for those files?

Thanks
        Bernd
--
----------------------------
Bernd Schandl
Department of Mathematical Sciences
Clemson University
Clemson, SC 29634-1907
USA

2. \DeclareMathSymbol question

3. Adding C-code plug-ins to Emacs?

4. DDE: Notes - PDF - can it be done easily?

5. EMACS/AUCTEX and dtx/ins file types

6. Help with Data Base

7. Adding C-code plug-ins to Emacs?

8. Looking for Documentation on Power Trust A2998A UPS

9. Why doesn't the mouse work with JED (dos version)?

10. C-x C-c doesn't work with 'xemacs -nw -q'

11. HELP: GNUS posting doesn't work in XEmacs 19.11...

12. Gnu emacs, HP-UX 11, remote Linux with non-US keyboard: AltGr doesn't work

13. GNU emacs 19.34.1 on Windows NT - server-start doesn't work