PicStart Plus programmer always locks

PicStart Plus programmer always locks

Post by Dylan Horvat » Wed, 30 Sep 1998 04:00:00



I am using Windows 95 and the MPLAB 3.4 IDE with the Microchip's Picstart
Plus programmer to do PIC development. I have a very irritating problem that
reoccurs when I try to program my MCUs. Usually, say 9 times out of 10, when
I go to the "enable programmer" menu selection, it brings up the programming
window (indicating initial successful communication with the board) but it
is unable to program the part. It gives me a series of errors suggesting I
check the cable connection and power, etc. etc. This is extremely
irritating, and usually is only fixed by either restarting MP-LAB, or
sometimes restarting the whole computer. It is a trial and error effort to
program chips this way.

Has anyone had similar experiences, and if so, can you offer any solutions?
I tried messing around with my COM settings in 95, to no effect. I tried
switching COM ports, suspecting my port had problems, also to no effect.

TIA,

-Dylan
--------------------------------------------------------
 Dylan Horvath,

 
 
 

PicStart Plus programmer always locks

Post by Naic » Thu, 01 Oct 1998 04:00:00



> Has anyone had similar experiences, and if so, can you offer any solutions?
> I tried messing around with my COM settings in 95, to no effect. I tried
> switching COM ports, suspecting my port had problems, also to no effect.

I get that too.  Usually about 50% of the time.  It is very annoying and I
haven't found a cure yet.

Naich.
--
 .------------------------------------------.
 | Faith is believing in things when common |   .-------------------.
 | sense tells you not to .-----------------'   | http://i.am/naich |
 `------------------------'                     `-------------------'

 
 
 

PicStart Plus programmer always locks

Post by Nematod » Thu, 01 Oct 1998 04:00:00


I have met problems with programming PIC16F84 micros, These are less
tolerant to the +12v Programming volts being low. Where as the PIC16C84 does
not mind this being an odd volt or two less. May not be your problem, But
worth checking

Regard
                Nematode

 
 
 

PicStart Plus programmer always locks

Post by Steve Simpso » Thu, 01 Oct 1998 04:00:00


Yup I had a similar problem when I first acquired my PIC programmer about 2
years ago.  Seems to be a hardware probelsm since sending it back to
Microchip for a repalcement solved the problem.

Regards

Steve Simpson

 
 
 

PicStart Plus programmer always locks

Post by William Moy » Thu, 08 Oct 1998 04:00:00


 I found that turning off the 16500 FIFO's (in Win95/98) for the com port
seems to help the problem.


:
: > Has anyone had similar experiences, and if so, can you offer any solutions?
: > I tried messing around with my COM settings in 95, to no effect. I tried
: > switching COM ports, suspecting my port had problems, also to no effect.
:
: I get that too.  Usually about 50% of the time.  It is very annoying and I
: haven't found a cure yet.
:
: Naich.
: --
:  .------------------------------------------.
:  | Faith is believing in things when common |   .-------------------.
:  | sense tells you not to .-----------------'   | http://i.am/naich |
:  `------------------------'                     `-------------------'
:

 
 
 

PicStart Plus programmer always locks

Post by Dylan Horvat » Fri, 09 Oct 1998 04:00:00


> I found that turning off the 16500 FIFO's (in Win95/98) for the com port
>seems to help the problem.


Yup -- this worked for me too, along with turning ON hardware handshaking.
Thanks!

-Dylan



>:
>: > Has anyone had similar experiences, and if so, can you offer any
solutions?
>: > I tried messing around with my COM settings in 95, to no effect. I
tried
>: > switching COM ports, suspecting my port had problems, also to no
effect.
>:
>: I get that too.  Usually about 50% of the time.  It is very annoying and
I
>: haven't found a cure yet.
>:
>: Naich.
>: --
>:  .------------------------------------------.
>:  | Faith is believing in things when common |   .-------------------.
>:  | sense tells you not to .-----------------'   | http://i.am/naich |
>:  `------------------------'                     `-------------------'
>:

 
 
 

PicStart Plus programmer always locks

Post by Leon van Donge » Sat, 10 Oct 1998 04:00:00


Hello All,

I am just involved in the PIC world. Before I start programming I need to
have some interface between computer and PIC.
I want to build my own PIC-programmer interface which works with the MPLAB
software. I did download a few hardware-layouts but I do not know if these
work along with the MPLAB software component: PicStart Plus.
Due to the fact that this software looks fine to me I want to make use of
it.

Can anyone send me a layout of PIC-programmer. I would be very pleased.

Many thanks in advance.

My email address: