Problems modifying LATSYM (2^)

Problems modifying LATSYM (2^)

Post by Sacchi Annamar » Sat, 11 Jun 1994 21:44:21



Hello,

I have problems with a modified print symbiont working with LAT.
I started from the SINGLE-THREADED  LAT print symbiont written by
C.Lydick, I modified it as I wanted and this seemed ok.
Then I tried to make it MULTI-THREADED, with 16 streams.
While the tests are limited to few started queues and few jobs, the behaviour
seems to be good but when I test it more heavily (for example, I start ten
queues and I send two print jobs on every queue) the jobs stay STARTING or
PRINTING on the print queues.

At this time I enter the command:

SHOW PROCESS /CONTINUOUS /ID = nnnnnnnn
and this is the result:

                Process SYMBIONT_nnn                      

State                   LEF                     Working set              756
Cur/base priority       4/4                     Virtual pages           3944
Current PC              7FFEE44C                CPU time     000:00:00:01.60            
Current PSL             03C00004                Direct I/O                80
Current user SP         7FF73118                Buffered I/O             159
PID                     20600573                Page faults              905
UIC                     [SYSTEM]                Event flags         E0000000
                                                                    00000000

Again, if I invoke TSM to see the status of the ports on which are defined the
devices LTA, I see :

port status                     IDLE
input/output Flow Control       No/No
DSR In/DTR Out                  Yes/Yes
Current service                 None

If I DELETE the corresponding entries, the job status becomes ABORTING until
I give STOP /QUEUE /RESET queue_name.
Again, the process SYMBIONT_nn created survives also after the STOP /RESET of
the last queue, so I must stop it with STOP/ID=nnnnnnnn.

Have you any ideas about it, also suggestion about tests that will address me
on the right way?

(VMS/VAX Version 5.5-2)

Many thanks in advance

---------------------------------------------------------------------------
Annamaria Sacchi, SIC                                   tel. +39 2 2125 344
CESI, Centro Elettrotecnico Sperimentale Italiano       fax  +39 2 2125 520

 
 
 

1. Problems modifying LATSYM

Hello,

I have problems with a modified print symbiont working with LAT.
I started from the SINGLE-THREADED  LAT print symbiont written by
C.Lydick, I modified it as I wanted and this seemed ok.
Then I tried to make it MULTI-THREADED, with 16 streams.
While the tests are limited to few started queues and few jobs, the behaviour
seems to be good but when I test it more heavily (for example, I start ten
queues and I send two print jobs on every queue) the jobs stay STARTING or
PRINTING on the print queues.
If I DELETE the corresponding entries, the job status becomes ABORTING until
I give STOP /QUEUE /RESET queue_name.
Again, the process SYMBIONT_nn created survives also after the STOP /RESET of
the last queue, so I must stop it with STOP/ID=nnnnnn.

Have you any ideas about it, also suggestion about tests that will address me
on the right way?

(VMS/VAX Version 5.5-2)

Many thanks in advance

2. lifespan on typeface design patents

3. Help Modify LATSYM

4. SPEC/PERFECT info sources (16/28) c.be. FAQ

5. Modifying LATSYM???

6. OS/2 Users' Group Meeting, Chicago, Illinois

7. VMS 6.1 LATSYM and Wordperfect - disconnect problem is fixed

8. Problems with VMS 4.6 and LTDRIVER & LATSYM

9. LATSYM won't disconnect to Emulex NETque port

10. Printing from LATSYM queue to HPLJ3si