need help opening libs in gcc

need help opening libs in gcc

Post by Bazooka J » Sat, 10 Dec 1994 05:55:13



I working through Compute's "learning C, programming graphics on the
amiga and atari st" This book trys not to be machine secific and as such
it never goes into detail about opening libraries, instead it suplies a
chunk of code which is suposed to do this for you. here's a line:
        OpenLibrary("intuition.library", OL)
gcc chokes on the `OL' I have no idea what it's for. I would be greatful
for any help.
        thanks

 
 
 

need help opening libs in gcc

Post by Christian Stieb » Sun, 11 Dec 1994 01:00:07



>    OpenLibrary("intuition.library", OL)
> gcc chokes on the `OL' I have no idea what it's for. I would be greatful
> for any help.

It is the minimum version of the library required. 0 means any version.
The reason the compiler complains is: you probably typed the letter "O"
instead of the digit "0" (zero). Try using "0" (zero).

Christian

--

\//    Certified Amiga Developer         PGP public key available
--------------------------------------------------------------------------
    "Life starts at '030, fun starts at '040, impotence starts at '86"
              keyboard not connected -- press F1 to continue

 
 
 

need help opening libs in gcc

Post by DAVID BALAZ » Tue, 13 Dec 1994 22:15:23



> I working through Compute's "learning C, programming graphics on the
> amiga and atari st" This book trys not to be machine secific and as such
> it never goes into detail about opening libraries, instead it suplies a
> chunk of code which is suposed to do this for you. here's a line:
>    OpenLibrary("intuition.library", OL)
> gcc chokes on the `OL' I have no idea what it's for. I would be greatful
> for any help.

Try just '0' instead of '0L'.

>    thanks


--

-----------------------------------------------------------------------

Amiga 1200                                                  .
Quantum LPS340A                           Slovenija, moja dezela.
-----------------------------------------------------------------------

 
 
 

need help opening libs in gcc

Post by Darrell Graing » Wed, 14 Dec 1994 05:00:23





>> I working through Compute's "learning C, programming graphics on the
>> amiga and atari st" This book trys not to be machine secific and as such
>> it never goes into detail about opening libraries, instead it suplies a
>> chunk of code which is suposed to do this for you. here's a line:
>>        OpenLibrary("intuition.library", OL)
>> gcc chokes on the `OL' I have no idea what it's for. I would be greatful
>> for any help.

>Try just '0' instead of '0L'.

Actually, the problem is not the L since the second parameter to OpenLibrary
is a long value. The problem is that Bazooka Joe is using the letter O and
not the number 0. So the change should be OL to 0L.

If you cannot see the difference then change your character set to something
like cleanibm.font.

>>        thanks

>--

>-----------------------------------------------------------------------

>Amiga 1200                                                  .
>Quantum LPS340A                           Slovenija, moja dezela.
>-----------------------------------------------------------------------

--
      /// Darrell Grainger  | Chaotic Knights BBS (905) 272-1860


  \XX/ ---------------------+---------------------------------------
 
 
 

1. gcc 2.2.2 error with gcc:lib/libgcc.a

since I installed the patches there has been an error
with gcc:lib/libgcc.a;-

ld: malformatted header of archive member in gcc:lib/libgcc.a

can someone please send me the file libgcc.a as I haven't got the
space on my HD to unpack the original

thanks
        Anthony


2. default delivery address for mail?

3. Help!Cant open Mathtrans.libs

4. reverse indices

5. StormC and lib auto open

6. put: DB_PAGE_NOTFOUND: Requested page not found ,,why?

7. opening muimaster.library from another lib

8. E-mail Outlook Problem. Please HELP!

9. Opening libraries not in LIBS:

10. Open Libs & Resident PRG

11. 1902A Pin-ins [still] needed

12. Help:68040.lib V37.30 needed

13. Help needed: midi.lib