Problem with Script-Fu/Logos

Problem with Script-Fu/Logos

Post by Michael Velte » Mon, 27 Nov 2000 04:00:00



Hello.

I've made an image via 'Xtns/Script-Fu/Logos/..' and saved it in
'jpeg' format. When I now open the image, shadow and other effects
were lost. I only see a poor looking image. :(
I even tried some other formats with the same result.

What can be the problem?

Thanks
Michael

 
 
 

Problem with Script-Fu/Logos

Post by Michael Spun » Mon, 27 Nov 2000 04:00:00


Hi!

Quote:> I've made an image via 'Xtns/Script-Fu/Logos/..' and saved it in
> 'jpeg' format. When I now open the image, shadow and other effects
> were lost. I only see a poor looking image. :(
> I even tried some other formats with the same result.
> What can be the problem?

The JPEG format among with other formats doesn't support multiple
layers. The most images created by Script-fu consist of multiple layers.
If you try to save such an image, only the active layer (ie mostly the
uppermost) is saved. So, you have to flatten your image first
(<Image>-Layers-Flatten image) in order to save it.

--

CU, Michael


---=[ http://technoid.xodox.com ]=---

 
 
 

Problem with Script-Fu/Logos

Post by Michael Velte » Mon, 27 Nov 2000 04:00:00



Quote:>> I've made an image via 'Xtns/Script-Fu/Logos/..' and saved it in
>> 'jpeg' format. When I open the image now, shadows and other effects
>> are lost. I only see a poor looking image. :(
> The JPEG format among with other formats doesn't support multiple
> layers. The most images created by Script-fu consist of multiple layers.
> If you try to save such an image, only the active layer (ie mostly the
> uppermost) is saved. So, you have to flatten your image first
> (<Image>-Layers-Flatten image) in order to save it.

Thank you Michael, it's working.

Michael

 
 
 

1. Help Problem PERL-Fu script logo creation

i want to automate logo creation
with the script

-------------- log.pl ------------------
#!/usr/local/bin/perl

use Gimp ":auto";
use Gimp::Fu;

Gimp::init;

script_fu_alien_glow_logo("hello hello", "70", "-*-utopia-bold-r-*-*-70-*-*-*-*-*-*-*", [122,122,122] );

exit main();
--------------------------------------

i want to save it in the file /tmp/bl.png  

# perl log.pl  -o /tmp/bl.png

but i get the error:

log.pl: required callback 'net' not found (ERROR)

----
Where is my error?

thanks,
Valter

2. Be a Beta Tester!

3. Vertical text input in script-fu logos

4. What is the max resolution for an Epson 1280 (2880x720 dpi) printer?

5. Script-Fu Question > Alpha to Logo

6. O.k, let's get some things clear...

7. Error in Script Fu Logos

8. create website-buttons using script-fu->logos

9. script Fu : Fire effects on text / Logos

10. Gimp Script-Fu logo samples available

11. Script-fu logos not working

12. Script-Fu from Perl-Fu non-interactively