gimp-1.3.15 compilation problem

gimp-1.3.15 compilation problem

Post by Jürgen Koslowsk » Wed, 18 Jun 2003 21:41:01



Hello,

Since about gimp-1.3.11 I haven't been able to compile new versions.  
The latest one ends with the following message when linking:

mkdir .libs
gcc -g -O2 -Wall -o .libs/gimp-1.3 app_procs.o main.o batch.o errors.o libgimp_glue.o -Wl,--export-dynamic -Wl,--export-dynamic -Wl,--export-dynamic  config/libappconfig.a gui/libappgui.a display/libappdisplay.a tools/libapptools.a widgets/libappwidgets.a core/libappcore.a pdb/libapppdb.a paint/libapppaint.a text/libapptext.a xcf/libappxcf.a vectors/libappvectors.a file/libappfile.a plug-in/libappplug-in.a paint-funcs/libapppaint-funcs.a base/libappbase.a ../libgimpcolor/.libs/libgimpcolor-1.3.so ../libgim
pmath/.libs/libgimpmath-1.3.so ../libgimpbase/.libs/libgimpbase-1.3.so ../libgimpmodule/.libs/libgimpmodule-1.3.so /cd-img/src/gimp-1.3.15/libgimpbase/.libs/libgimpbase-1.3.so ../libgimpwidgets/.libs/libgimpwidgets-1.3.so /cd-img/src/gimp-1.3.15/libgimpcolor/.libs/libgimpcolor-1.3.so /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangox-1.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libgobject-2.0.so /usr/lib/libg
module-2.0.so -ldl /usr/lib/libglib-2.0.so /usr/lib/libart_lgpl_2.so -lm /usr/lib/libfontconfig.so /usr/lib/libfreetype.so -lz /usr/lib/libexpat.so
/usr/bin/ld: Dwarf Error: Invalid or unhandled FORM value: 14.
gui/libappgui.a(plug-in-menus.o):/cd-img/src/gimp-1.3.15/app/gui/plug-in-menus.c:78: undefined reference to `bind_textdomain_codeset'
gui/libappgui.a(plug-in-menus.o):/cd-img/src/gimp-1.3.15/app/gui/plug-in-menus.c:107: undefined reference to `bind_textdomain_codeset'
collect2: ld returned 1 exit status
make[3]: *** [gimp-1.3] Error 1
make[3]: Leaving directory `/cd-img/src/gimp-1.3.15/app'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/cd-img/src/gimp-1.3.15/app'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/cd-img/src/gimp-1.3.15'
make: *** [all] Error 2

Any ideas?

-- Juergen

--
Juergen Koslowski               If I don't see you no more on this world
ITI, TU Braunschweig               I'll meet you on the next one

http://www.iti.cs.tu-bs.de/~koslowj      Jimi Hendrix (Voodoo Child, SR)

 
 
 

gimp-1.3.15 compilation problem

Post by Dave Near » Thu, 19 Jun 2003 05:35:05


On 17 Jun 2003 12:41:01 GMT, Jrgen Koslowski said:

Quote:> Hello,

> Since about gimp-1.3.11 I haven't been able to compile new versions.  
> The latest one ends with the following message when linking:

Just wondering... have you removed the old distributions lately?
Is it possible that the new stuff is polluting the new distro?
Have you done a make uninstall, then checked out a fresh copy to
see what happens?

Quote:> /usr/bin/ld: Dwarf Error: Invalid or unhandled FORM value: 14.

This error looks weird... but kind of tallies with what I say
below. Kind of looks like some magic number not matching up.

Quote:> gui/libappgui.a(plug-in-menus.o):/cd-img/src/gimp-1.3.15/app/
> gui/plug-in-menus.c:78: undefined reference to
> `bind_textdomain_codeset'
> gui/libappgui.a(plug-in-menus.o):/cd-img/src/gimp-1.3.15/app/
> gui/plug-in-menus.c:107: undefined reference to
> `bind_textdomain_codeset'

These two are also odd, since bind_textdomain_codeset is defined
in glibc 2.2 - normally you wouldn't be linking against it unless
you had half an old libc and half a new libc lying around... did
you upgrade glibc recently? Could be the source of your problems
if you're compiling against new headers and an old libc library.

Quote:> Any ideas?

That's just about it.

--
                David Neary,
        E-Mail: bolsh at gimp dot org
   Work e-mail: d dot neary at phenix dot fr
CV: http://www.redbrick.dcu.ie/~bolsh/CV/CV.html

 
 
 

1. GIMP compilation problem - Perl

Hi there. I have following problem while running configure script:

________________________________
Warning: prerequisite Parse::RecDescent failed to load: Can't locate
Parse/RecDe

/usr/lib/perl5/
5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux
/usr/lib/perl5/site_perl/5.6.0 /
usr/lib/perl5/site_perl) at (eval 18) line 3.

Error: Unable to locate installed Perl libraries or Perl source code.

It is recommended that you install perl in a standard location before
building extensions. Some precompiled versions of perl do not contain
these header files, so you cannot build extensions. In such a case,
please build and install your perl from a fresh perl distribution. It
usually solves this kind of problem.

(You get this message, because MakeMaker could not find
"/usr/lib/perl5/5.6.0/i3
86-linux/CORE/perl.h")
_____________________-

Indeed, there's no perl.h file in that directory  (there's libperl.so
instead).
I have installed Perl from Mandrake8.0 distribution (by rpm). My Perl seems
to be installed in /usr/lib/perl5/5.6.0 directory.
Anybody knows how to fix it ?

Dante

2. Printing images for copying - how?

3. gimp compilation problem

4. minimum diameter of spanning tree

5. Gimp 1.1.12 compilation problem

6. Rotating in non-world coordinates

7. Gimp-1.1.13; problems at compilation

8. Gimp-1.1.13 - Compilation problems

9. Gimp-1.3.15 toolbox customize

10. batching Windows, GIMP stalls after 15 or so runs

11. *FS: WACOM 15 x 15 for Mac plus digitizer

12. GIMP Compilation Woes....