Gimp Print 4.3.12 on Debian Woody

Gimp Print 4.3.12 on Debian Woody

Post by bl » Sat, 03 May 2003 08:19:42



Has anyone gotten Gimp-Print 4.3.12 to work on Debian woody.  I have
tried to install it and have been unsuccessful.  I have all of the
dependent packages installed, but I get the following error when I run
debuild.  I am new to linux, but it appaars that I might be missing
somemthing (-lpng) in /usr/lib/libjpeg.so (-lpng ?? what is this?).
Any ideas?

mkdir .libs gcc -Wall -Wcast-align -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wnested-externs
-Wwrite-strings -pedantic -Werror-implicit-function-declaration
-Winline -I../../include -I../../include -I../../intl -g -O2 -o
cups-calibrate cups-calibrate.o ../../lib/.libs/libprintut.a -lm
source='epson.c' object='epson.o' libtool=no \
depfile='.deps/epson.Po' tmpdepfile='.deps/epson.TPo' \ depmode=gcc
/bin/sh ../../scripts/depcomp \ gcc -DHAVE_CONFIG_H -I. -I. -I../..
-DGENPPD_PPD_PREFIX=\"/usr/share/cups/model/gimp-print/gimp-print\"
-DGIMP_PRINT_VERSION=\"4.3.12\" -I. -I. -I../.. -Wall -Wcast-align
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -Wwrite-strings -pedantic
-Werror-implicit-function-declaration -Winline -I../../include
-I../../include -I../../intl -g -O2 -c `test -f 'epson.c' || echo
'./'`epson.c /bin/sh ../../libtool --mode=link gcc -Wall -Wcast-align
-Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
-Wnested-externs -Wwrite-strings -pedantic
-Werror-implicit-function-declaration -Winline -I../../include
-I../../include -I../../intl -g -O2 -o epson epson.o
../../lib/libprintut.la -lcupsimage -ltiff -ljpeg -lpng -lm -lz -lcups
-lssl -lcrypto -lnsl gcc -Wall -Wcast-align -Wstrict-prototypes
-Wmissing-prototypes -Wmissing-declarations -Wnested-externs
-Wwrite-strings -pedantic -Werror-implicit-function-declaration
-Winline -I../../include -I../../include -I../../intl -g -O2 -o epson
epson.o ../../lib/.libs/libprintut.a -lcupsimage -ltiff
/usr/lib/libjpeg.so -lpng -lm -lz -lcups -lssl -lcrypto -lnsl
/usr/bin/ld: cannot find -lpng
collect2: ld returned 1 exit status
make[3]: *** [epson] Error 1 make[3]: Leaving directory
`/home/brent/Download/Gimp-print/gimp-print-4.3.12/src/cups'
make[2]: *** [all-recursive] Error 1 make[2]: Leaving directory
`/home/brent/Download/Gimp-print/gimp-print-4.3.12/src'
make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory
`/home/brent/Download/Gimp-print/gimp-print-4.3.12' make: *** [all]
Error 2

 
 
 

Gimp Print 4.3.12 on Debian Woody

Post by Marc 'BlackJack' Rintsc » Sat, 03 May 2003 18:00:37



> Has anyone gotten Gimp-Print 4.3.12 to work on Debian woody.  I have
> tried to install it and have been unsuccessful.  I have all of the
> dependent packages installed, but I get the following error when I run
> debuild.  I am new to linux, but it appaars that I might be missing
> somemthing (-lpng) in /usr/lib/libjpeg.so (-lpng ?? what is this?).
> Any ideas?

It's the PNG library. Maybe it's not installed or not in the LD Path.

Ciao,
        Marc 'BlackJack' Rintsch

 
 
 

1. Debian 3.0 Woody

For ten months I've run SuSE 7.1 PPC on an external SCSI hard disk.
Vanilla install, KDE default.  Potato 2.2.18.  Beige 266MHz G3.
Generally I've been pleased.  But I'd like to give GNOME a try, so
maybe this is a good excuse to install Debian Woody 3.0, thus giving
GNOME a chance to really shine.  I've been reading horror stories
about the installation process over at Slashdot.  Lack of hardware
recognition is maybe not so much of a problem because that info is
easier to access on the Mac OS side.

Your observations, please.  I'm a cartoonist, I really like GIMP.
I've got a slow net connection so I'd have to buy the installation
CD-ROMs. <http://www.alldebian.com/> The cost is fairly trivial.

--

"Don't forget to register to vote" - Frank Zappa

2. Video bug in nt sp5?

3. Gimp, Debian und Fonts on 7110

4. Fractals landscapes

5. Can't print from Gimp with CUPS + Gimp-print 4.1.00-b1

6. Video Editing with PC

7. gimp does NOT recognize gimp-print

8. gnuplot 3.6

9. Installing gimp-print not recognized by Gimp

10. gimp print not printing

11. woody please!!!

12. woody!!