Gimp 1.2.3 - Script-Fu freezing

Gimp 1.2.3 - Script-Fu freezing

Post by --==[bman]==- » Thu, 15 May 2003 10:35:06



I've noticed that after using for a while Script-Fu-Shadow-Xach-Effect,
GIMP tends to freeze on me.  I mean, when I am done and try to quit, it
freezes.  I have to kill Script-Fu's process first on the console followed
by a kill of GIMP itself.

I admit that my machine with 250Mb of RAM is probably not the ideal
graphics' station but for my modest needs it is sufficient.  Has anybody
come across this behavior?

Thanks.

 
 
 

Gimp 1.2.3 - Script-Fu freezing

Post by Michael Schumache » Thu, 15 May 2003 19:01:46



> I've noticed that after using for a while Script-Fu-Shadow-Xach-Effect,
> GIMP tends to freeze on me.  I mean, when I am done and try to quit, it
> freezes.  I have to kill Script-Fu's process first on the console followed
> by a kill of GIMP itself.

Script-Fu suffers from memory leaks, so if you use it repeatedly, this
may add up...

Good thing is that most of them have been identified and fixed, so the
upcoming 1.2.4 leak less.

See
http://bugzilla.gnome.org/show_bug.cgi?id=86586

HTH,
Michael

 
 
 

Gimp 1.2.3 - Script-Fu freezing

Post by --==[bman]==- » Fri, 16 May 2003 09:38:03


Thanks Michael.  Now at least I'm sure it wasn't me... :)


>> I've noticed that after using for a while Script-Fu-Shadow-Xach-Effect,
>> GIMP tends to freeze on me.  I mean, when I am done and try to quit, it
>> freezes.  I have to kill Script-Fu's process first on the console
>> followed by a kill of GIMP itself.

> Script-Fu suffers from memory leaks, so if you use it repeatedly, this
> may add up...

> Good thing is that most of them have been identified and fixed, so the
> upcoming 1.2.4 leak less.

> See
> http://bugzilla.gnome.org/show_bug.cgi?id=86586

> HTH,
> Michael

 
 
 

1. Script-fu GIMP 1.2 Win32 GPF's gimp

Everytime I use a script with Gimp 1.2 for win32, I close the generated
picture, and gimp GPF's.
There is always a script-fu task left which I have to kill first before
restarting gimp.
OS: Win98SE, good Graphics card, enough memory/Athlon Thunderbird CPU
etc.
Additional info: NO program in Background except Explorer.exe (not even
systray).

Is this a known bug or does it not like my Machine?
The Machine itself is very stable (for Windows98 typical conditions).
Gimp 1.1 ran without problems.

(No "use linux" replies please, I already do since 1.3.13..)

Joachim

2. View-dependent data structures for ray-tracing

3. Newbie script-fu question (null arguments from Gimp)

4. Tiling a Jpeg

5. Compiled Gimp 1.2.2 hangs up when loading script-fu

6. Using plug-in

7. gimp script-fu question

8. WIN-GIMP: Refresh of Script-Fu unstable?

9. Gimp Script-Fu logo samples available

10. gimp 1.1.10 and script-fu

11. strange gimp 1.[01].x script-fu(?) problem

12. SCRIPT-FU: gimp-file-save