DirectX 9.0a not loading from Microsoft

DirectX 9.0a not loading from Microsoft

Post by Paul Fishwic » Thu, 03 Jul 2003 00:31:43



One of my machines (Windows XP currently running
DirectX 8.1 according to dxdiag), when i try to
upgrade to 9.0a, I continue to get an error message
from the DirectX dxwebsetup installer, stating that
it is unable to download the files. The net connection
is fine for the machine (ftp,tcp/ip all appear to
work OK). If there was a way to get the whole
directx9.0a installation, that might work, but the
dxwebsetup, which attempts to download files from
MS, is failing. Any ideas?
 
 
 

DirectX 9.0a not loading from Microsoft

Post by MVP » Thu, 03 Jul 2003 03:51:36


Do you have an MSDN subscription?  DX downloads are available there,
although I haven't checked if 9.0a is there yet.

 
 
 

DirectX 9.0a not loading from Microsoft

Post by Paul Fishwic » Thu, 03 Jul 2003 08:43:46


I am not sure..but I looked at dxdiag and have
another theory as to why the dxwebetup is
malfunctioning. I installed DirectX 9 BETA when
it first came out since I have an ATI 9700 which
supported it. When I run dxdiag, I see that the
following is under the "DIRECTX tab":

Several files are beta versions ...which
are unsupported and may cause problems

dxdiag shows that I have DirectX 8.1 but I know
that I have the beta verson of DirectX 9.0 installed.
This is catch-22: to get around this, I need to install
the latest, non-beta, 9.0 drivers, but the websetup
fails most likely because it will not upgrade a
beta version.

-paul

Quote:>-----Original Message-----
>Do you have an MSDN subscription?  DX downloads are
available there,
>although I haven't checked if 9.0a is there yet.

>.

 
 
 

DirectX 9.0a not loading from Microsoft

Post by Eyal Tele » Fri, 04 Jul 2003 23:55:02


Have you tried downloading the offline version and installing that?

        Eyal


> I am not sure..but I looked at dxdiag and have
> another theory as to why the dxwebetup is
> malfunctioning. I installed DirectX 9 BETA when
> it first came out since I have an ATI 9700 which
> supported it. When I run dxdiag, I see that the
> following is under the "DIRECTX tab":

> Several files are beta versions ...which
> are unsupported and may cause problems

> dxdiag shows that I have DirectX 8.1 but I know
> that I have the beta verson of DirectX 9.0 installed.
> This is catch-22: to get around this, I need to install
> the latest, non-beta, 9.0 drivers, but the websetup
> fails most likely because it will not upgrade a
> beta version.

> -paul

>>-----Original Message-----
>>Do you have an MSDN subscription?  DX downloads are

> available there,

>>although I haven't checked if 9.0a is there yet.

>>.

 
 
 

DirectX 9.0a not loading from Microsoft

Post by Paul Fishwic » Fri, 04 Jul 2003 23:35:28


I found a "developer run-time" directx version
for 9.0a, and ran this. Despite some odd reboots
that I had to do, it finally worked fine. I wonder
if anyone else has tried to upgrade from the Beta
version of DirectX 9, or perhaps my case was a fluke?
-paul

Quote:>-----Original Message-----
>One of my machines (Windows XP currently running
>DirectX 8.1 according to dxdiag), when i try to
>upgrade to 9.0a, I continue to get an error message
>from the DirectX dxwebsetup installer, stating that
>it is unable to download the files. The net connection
>is fine for the machine (ftp,tcp/ip all appear to
>work OK). If there was a way to get the whole
>directx9.0a installation, that might work, but the
>dxwebsetup, which attempts to download files from
>MS, is failing. Any ideas?
>.

 
 
 

DirectX 9.0a not loading from Microsoft

Post by Eyal Tele » Sat, 05 Jul 2003 08:30:26


I'd guess that most beta users upgraded to DX9, and not to DX9a, and
that the DX9 update didn't have that problem. I find it curious that
you stayed with the beta until now.

        Eyal


> I found a "developer run-time" directx version
> for 9.0a, and ran this. Despite some odd reboots
> that I had to do, it finally worked fine. I wonder
> if anyone else has tried to upgrade from the Beta
> version of DirectX 9, or perhaps my case was a fluke?
> -paul

>>-----Original Message-----
>>One of my machines (Windows XP currently running
>>DirectX 8.1 according to dxdiag), when i try to
>>upgrade to 9.0a, I continue to get an error message

>>from the DirectX dxwebsetup installer, stating that

>>it is unable to download the files. The net connection
>>is fine for the machine (ftp,tcp/ip all appear to
>>work OK). If there was a way to get the whole
>>directx9.0a installation, that might work, but the
>>dxwebsetup, which attempts to download files from
>>MS, is failing. Any ideas?
>>.