problems with TGS inventor port?

problems with TGS inventor port?

Post by Jeff Whi » Tue, 26 Sep 1995 04:00:00



Forgive me if this has already come up..

Has anyone experienced problems with the TGS Sun port of inventor?
Specifically any function that has parameters of a 2d array, like
SoMFColor::setVAlues() or SoMFString::setValues() etc.  They are
listed in the header files, but don't seem to be in the libs themself.
I can't find them using nm.

And I also can't get anything with SbMat parameter to work.  For
example

   SbMat m;
   SbMatrix *x=new SbMatrix(m);

causes the compiler to say:

Error: Could not find a match for SbMatrix::SbMatrix(float[4][4]).

I tried making m explicitly a float[4][4], to no avail..  

thanks,
jeff
--
 --------------------------------------------------------------------

| "So you run and you run to catch up with the sun but it's sinking  |
| Racing around to come up behind you again" - pink floyd            |
 --------------------------------------------------------------------

 
 
 

1. TGS Inventor on WinNT Server problems...

Hello all (Probably Mike...)
    Have there been any reported problems with TGS's OpenInventor on
WinNT Server 4.0 Fixpack 5 (128 bit encryption if that matters), running
with dual 550 MHZ Pentium III's?

Here is the situation:
I have installed The above OS.
Microsoft Visual C++ 6.0 with fixpack 3,
OpenInventor 2.5.2 (TGS)
Graphics card is a Creative Labs Riva TNT2 Ultra.

I installed OI, then rebooted. I used the IVF class wizard to generate a
simple app with all the defaults (SDI). Everything compiles and links,
but when I run I allways get this error:

Debug Assertion Failed!
Program: <ProgramName here>
File: wingdi.cpp
Line: 832

Pressing retry to debug the application does nothing.

As this is happening with 'empty'/default applications generated with
IVF wizard I'm starting to think that it's an incompatibility with NT
server and/or the above combination of fixpacks?

Anyone have any suggestions?

        regards,
                        Paul J. Rider.

2. Fast AA polygon scan conversion (A-Buffer)

3. Transparency problem in TGS Inventor 2.5.2?

4. LW and MAX files

5. TGS Open Inventor NT Font problem

6. OSX <---> Win2000

7. HELP: Problems with Inventor porting

8. Porting IRIX Inventor to Inventor 2.0

9. Colortables on OI-Solaris-Port from TGS

10. Cosmo OpenGL and TGS Open Inventor 2.21?

11. TGS OpenGl/Inventor (Solaris): Colormaps on 8-Bit Systems

12. ANNCE: VRML 2.0 C++ Toolkit From TGS Bundled in Open Inventor