Why doesn't PM tracking work?

Why doesn't PM tracking work?

Post by Stephen M. Henni » Mon, 23 Oct 1995 04:00:00



I recently found a tracking problem when Pagemaker prints.  I have done
some tests and found a work around but don't fully understand the problem
since the same PICT text will print properly in Canvas, Clarisworks,
MacDraw, Simpletext, Superpaint and WriteNow.  However, when imported into
Pagemaker what should print as

Firstname   Lastname        will print as
F i r s t n a m eL a s t n a m e      with the e & L overlapping

What I find is that letters are further apart than they should be and the
space between words disappears and the letters overlap.  
I conducted a series of tests with cursive fonts that I use which include
proportional Type 1 fonts: CoventryScriptFLF , Freestyle Script,
PalaceScriptMT , PreludeScriptFLF , RegencyScriptFLF, SnellRoundhandScript
, and ZephyrScriptFLF as well as the proportional TrueType font Signature.
It does not matter what PageMaker preferences I select (i.e. "use ATM", TT
line spacing, TT character shape).  However, it is very sensitive to
whether tracking is on and whether I have selected type style BOLD.
Here are the results.
No problem with tracking turned off except for one Type 1 font,
SnellRoundhandScript, which when used with type style BOLD, the spacing
between letters became too great when printed but looked great on the
screen.
With tracking turned on to normal, there was a problem with all fonts and
no matter what type style was selected.  The space-character seemed to
vanish on printed text, but there was no problem on the screen.  The
spacing between letters was still too great for the SnellRoundhandScript
when type style BOLD was selected during printing but was OK on the
screen.
My work around is to 1) not use tracking, and to 2) not use BOLD with
SnellRoundhandScript.
Specifics: PageMaker 4.2, System 7.1, Update 2, ATM 3.6, Duo 230,12M Ram,
HP DeskWriter C with driver 6.0.

--
Cheers, Steve Henning in Reading, PA   USA

 
 
 

Why doesn't PM tracking work?

Post by Steve Mill » Mon, 23 Oct 1995 04:00:00




> I recently found a tracking problem when Pagemaker prints.  I have done
> some tests and found a work around ...
> No problem with tracking turned off except for one Type 1 font,
> SnellRoundhandScript, which when used with type style BOLD, the spacing
> between letters became too great when printed but looked great on the
> screen.
> With tracking turned on to normal, there was a problem with all fonts and
> no matter what type style was selected.  The space-character seemed to
> vanish on printed text, but there was no problem on the screen.  The
> spacing between letters was still too great for the SnellRoundhandScript
> when type style BOLD was selected during printing but was OK on the
> screen.
> My work around is to 1) not use tracking, and to 2) not use BOLD with
> SnellRoundhandScript...
> --
> Cheers, Steve Henning in Reading, PA   USA

Well, you've certainly identified part of the problem--artificial
emboldening on fonts. Snell Roundhand doesn't have a corresponding bold
like the Helvetica and Times families. When you apply bold, your screen
display will show but, but without an outline font, the printer just
prints the default character. Type 1 fonts are kinda funny that way--they
print the way the designer designed 'em!

 
 
 

Why doesn't PM tracking work?

Post by Steve Mill » Mon, 23 Oct 1995 04:00:00




> I recently found a tracking problem when Pagemaker prints.  I have done
> some tests and found a work around ...
> No problem with tracking turned off except for one Type 1 font,
> SnellRoundhandScript, which when used with type style BOLD, the spacing
> between letters became too great when printed but looked great on the
> screen.
> With tracking turned on to normal, there was a problem with all fonts and
> no matter what type style was selected.  The space-character seemed to
> vanish on printed text, but there was no problem on the screen.  The
> spacing between letters was still too great for the SnellRoundhandScript
> when type style BOLD was selected during printing but was OK on the
> screen.
> My work around is to 1) not use tracking, and to 2) not use BOLD with
> SnellRoundhandScript...
> --
> Cheers, Steve Henning in Reading, PA   USA

Well, you've certainly identified part of the problem--artificial
emboldening on fonts. Snell Roundhand doesn't have a corresponding bold
like the Helvetica and Times families. When you apply bold, your screen
display will show but, but without an outline font, the printer just
prints the default character. Type 1 fonts are kinda funny that way--they
print the way the designer designed 'em!
 
 
 

1. How to track down why my display list doesn't

I have 2 display lists (actually, I have about 30, but let's just talk
about 2 of them :)

When I made the display lists, I did very similar things,  (glBegin,
glTexCoord2, glVertex, glEnd, etc.)  I didn't get a glError.

When I display the lists, I don't get a glError.

But one of them displays, and the other doesn't.

Neither translates or rotates and, to help me debug, I view them both at
0,0,0.

There's no interviening code.  In order to try to track it down, I got
to the point of:

   ...
   glCallList (list1);
   glCallList (list2);
   ...

but list1 shows, and list2 doesn't.  (They're diverse enough shapes that
I should be able to see both.  Like a tall-skinny cube and a short-fat
cube.)

So... how would I go about tracking down the problem?  What's really
weird is I have bunches of display lists, and they all display except
this one.

Thanks!

--
Please take off your shoes before arriving at my in-box.
I will not, no matter how "good" the deal, patronise any business which sends
unsolicited commercial e-mail or that advertises in discussion newsgroups.

2. Shattering Objects in explosion

3. PM 6.5 Biz Card Template Script doesn't work

4. Blade Pro gems?

5. Why doesn't this work!?

6. AD:Family Reunion T Shirts & More

7. why doesn't this work

8. Why doesn't the history brush work?

9. newbie Q: why doesn't snowfall work?

10. why panorma plugin doesn't work???

11. why it doesn't work?

12. Why doesn't this work?