SGI OpenGL for windows crashes

SGI OpenGL for windows crashes

Post by Michael I. Gol » Thu, 11 Sep 1997 04:00:00



| I just installed the OpenGL SDK from SGI.  However, It always crashes
| right away with an illegal instruction error.  Using the de* I
| discovered that it happens somewhere in the wglMakeCurrent call.
| The Microsoft dll works fine, though.  Could it be an MMX
| instruction, perhaps?  I'm using a cyrix 6x86 p150+ with a Matrox
| Millenium.

Ahh, you must be the person who posted a bug last night but forgot to
sign a return address!  Otherwise I would have answered you personally.

This is a known problem which we plan to fix (soon).  Here is a
temporary workaround (thanks Mark!):


|
|   There is a bug in  SGI's OpenGL for Windows.  It uses the CPUID instruction
| which is not enabled in Cyrix processors by default.  You need to find a
| utility which will enable CPUID in your processor.  The one I use for Win95
| is on this page: http://www.veryComputer.com/
| 686_p.exe
--
Michael I. Gold     Silicon Graphics Inc.     http://www.veryComputer.com/
And my mama cried,  "Nanook a no no! Don't be a * eskimo! Save your
money, don't go to the show!"  Well I turned around and I said, "Ho! Ho!"

 
 
 

SGI OpenGL for windows crashes

Post by Gurupartap Davi » Thu, 11 Sep 1997 04:00:00


I just installed the OpenGL SDK from SGI.  However, It always crashes
right away
with an illegal instruction error.  Using the de* I discovered that
it happens
somewhere in the wglMakeCurrent call.  The Microsoft dll works fine,
though.
Could it be an MMX instruction, perhaps?  I'm using a cyrix 6x86 p150+
with a Matrox Millenium.

Thanks,
-partap