glut 3.5 NT installation troubles

glut 3.5 NT installation troubles

Post by Grand High Mast » Tue, 05 Aug 1997 04:00:00



I've just instaled GLUT 3.5 under NT 4.0. When I use Borland 4.5 to compile
a demo program, the compiler churns up an error whenver it hits a line
like this in gl.h:

WINGDIAPI void APIENTRY glCullFace (Glenum mode);

Seems like any line beginning with WINGDIAPI in gl.h causes BC 4.5 to give
the error

Declaration syntax error.

Any ideas?
--
| THE GRAND HIGH MASTER             (Steve Robinson) |    
|                                                    |  

|    1st Yr Comp Sci/Comp Sys Eng (RMIT City Campus) |

 
 
 

glut 3.5 NT installation troubles

Post by Michael I. Gol » Tue, 05 Aug 1997 04:00:00



| I've just instaled GLUT 3.5 under NT 4.0. When I use Borland 4.5 to compile
| a demo program, the compiler churns up an error whenver it hits a line
| like this in gl.h:
|
| WINGDIAPI void APIENTRY glCullFace (Glenum mode);

Generally this happens when you failed to include windows.h before gl.h.
Since you are using GLUT I suspect:

        #if defined(WIN32)
        #include <windows.h>
        #endif

you don't have WIN32 defined, or your application does this:

        #include <GL/gl.h>
        #include <GL/glut.h>

which defeats the logic in glut.h

Bottom line: make sure windows.h is included first.
--
Michael I. Gold     Silicon Graphics Inc.     http://www.veryComputer.com/
And my mama cried,  "Nanook a no no! Don't be a * eskimo! Save your
money, don't go to the show!"  Well I turned around and I said, "Ho! Ho!"