Help: Can't compile povray (IRIX 5.3 R5K indy)

Help: Can't compile povray (IRIX 5.3 R5K indy)

Post by John Bokm » Sun, 19 Apr 1998 04:00:00



I dowloaded Povray version 3.02.

after gzip -d the source files I get a warning about rubbish at the end of
the
file (I downloaded the file several times as a binary, still the same
warning).

But the main problem is... how to compile it.. The mess seems to consist of
three parts: zlib libpng and povray itself. Compiling zlib and libpng is a
huge
undertaking... why is there not a IRIX specific makefile which works
without
problems??? The povray makefile (-> unix) complains: Makefile 1473 Syntax
Error..

So what's next? Why is this distibution so hard to compile. I had no
problems
with good old version 2....

* So is there anyone around with the right makefiles which works?
   preferable IDO / IRIX 5.3. (I think it is not a bad idea to use -mips2
when
  compiling??)

* Or is there an optimized binary for a R5K Indy ?

* What's wrong with the source tgz file (rubish at the end, ignored??)

Many thanks in advance,

John

--
------------------------------------------------------------------
C A S T L E  A M B E R      Software Development (Java/Perl/C/CGI)

 
 
 

Help: Can't compile povray (IRIX 5.3 R5K indy)

Post by Enrique Jae » Tue, 21 Apr 1998 04:00:00


Greetings,
   I compiled povray 3.01 for an R5000 O2 (irix 6.3) with the SGI
compilers, version 7.1. I changed the gcc to cc in the makefiles.
There was an extra "/" at the end of line 220 that was causing
a Makefile error.
   If you cannot compile it, you can try to download a gzipped,
tarred distribution from my wed site. A link to the binaries is
on the page:
      http://ipanema.ams.sunysb.edu/~ejaen/graphics.html
   The executable (x-povray) is in the povray3 directory. I can't
remember which OBJECT_STYLE I used. If you know an easy way to check
please let me know. Also, let me know if you have any trouble with the
download.
   Good luck,
Enrique


> I dowloaded Povray version 3.02.

> after gzip -d the source files I get a warning about rubbish at the end of
> the
> file (I downloaded the file several times as a binary, still the same
> warning).

> But the main problem is... how to compile it.. The mess seems to consist of
> three parts: zlib libpng and povray itself. Compiling zlib and libpng is a
> huge
> undertaking... why is there not a IRIX specific makefile which works
> without
> problems??? The povray makefile (-> unix) complains: Makefile 1473 Syntax
> Error..

> So what's next? Why is this distibution so hard to compile. I had no
> problems
> with good old version 2....

> * So is there anyone around with the right makefiles which works?
>    preferable IDO / IRIX 5.3. (I think it is not a bad idea to use -mips2
> when
>   compiling??)

> * Or is there an optimized binary for a R5K Indy ?

> * What's wrong with the source tgz file (rubish at the end, ignored??)

> Many thanks in advance,

> John

> --
> ------------------------------------------------------------------
> C A S T L E  A M B E R      Software Development (Java/Perl/C/CGI)



 
 
 

1. SGI Indy R5K 192MB vs Indy R5K 64MB

I have used both and I can tell you that the O2 had its problems, having to
reboot quite often.  The Indy always seemed smoother. Definitely have lots of
memory.  The rendering in either 32 or 24 bit was indiscernable to me, but the
O2 was just on a 17 inch screen, so it couldnt have been a match for the Indy's
20 inch.  Either way, they are both slow compared to todays Wintels systems.

2. Vout on Crimson Reality Engine in VGA mode

3. 3d GRAPHICS BUGS ON INDY R4400XZ IRIX 5.3

4. FREE FILTER

5. Video BLACKout on Indy 46K (Irix 5.3)

6. Alias animator needed

7. Autocad Release 13 Display Problems/Irix 5.3/Sgi Indy

8. New Pencil, Inc.

9. videod falls over on Indy under IRIX 5.3

10. PBM compile IRIX 5.3

11. Compiling gnuplot_x11 on Irix 5.3

12. Compiling 3.5 on an Irix 5.3 machine

13. POVRAY for SGI Irix 5.3