Problem with mpeg-player on IRIX 5.3

Problem with mpeg-player on IRIX 5.3

Post by Reinhard Herz » Thu, 24 Oct 1996 04:00:00



Hardware:  
  SGI Crimson
  MIPS R4000
  128 MB Memory
  VGX Graphics
  GDM20D11 Color Graphic Display

System:
  IRIX 5.3, Product Codes SC4-W4D-5.3, SC4-S4D-5.3

Application:
  mpeg_play &
  mpeg2play V1.1a, 94/07/04,
  (C) 1994, Stefan Eckart & MPEG Software Simulation Group

---------------------------------------------------------------------------------------

Problem:  

1.: I start the mpeg-player or the mpeg2-player:
    1.1  mpeg_play test.mpeg
    1.2  mpeg2play test.mpeg

2.: There appears a white X-window for one or two seconds
    with the right solution (720x576).

3.: The programs write on stderr:

    3.1 mpeg-player:
    Shared memory error, disabling.  
    X Error of failed request:  BadMatch (invalid parameter attributes)
    Major opcode of failed request:  72 (X_PutImage)
    Serial number of failed request:  143
    Current serial number in output stream:  144

    3.2 mpeg2player:
    Shared memory error, disabling.  
    X Error of failed request:  BadMatch (invalid parameter attributes)
    Major opcode of failed request:  72 (X_PutImage)
    Serial number of failed request:  221
    Current serial number in output stream:  222

--------------------------------------------------------------------------------

Questions:

 *) Does anyone know more about these errors ?
 *) If not: Does there exist another SGI-mpeg-player on the web ?

Thank you very much for your help,
sincerely

Reinhard Herzog

-----------------------------------------------------------------------------



Elisabethstrasse 85/A1   Tel. +43-316-424500/41
A-8010 GRAZ              Fax. +43-316-424500/69

Bachlbergweg 63          Tel. +43-732-732683
A-4040 LINZ

                         A  U S T R I A

-----------------------------------------------------------------------------

 
 
 

1. Problem porting X application from IRIX 5.3 to IRIX 6.4

In porting C code containing the statement:

                if (!XStoreColor (......

the IRIX 6.4 cc compiler generates the error message:

        .... error(1041): expression must have arithmetic or pointer
type

The following difference was noted in the /usr/include/X11/Xlib.h file:

                v 5.3: external XStoreColor ( ......

                v 6.4: external void XStoreColor ( .......

Does this indicate a change in the X library?

2. Beginner in grapihic Design

3. IrisGL problem: IRIX 5.3 --> IRIX 6.2

4. (no subject given -- from Levent Organ)

5. Irix 5.3 DISPLAY Problem

6. Displaying Image Coords?

7. Galileo Installation Problem under IRIX 5.3

8. CorelDRAW! Tutorial has ben moved

9. IRIX 5.3 on an Impact -- X Windows problems

10. problem with movieplayer (IRIX 5.3)

11. Autocad Release 13 Display Problems/Irix 5.3/Sgi Indy

12. Problem with OpenInventor, IRIX 5.3 and personal iris.

13. Problem with Draggers with IRIX 5.3