Bug of Xsgi or xdm on IRIX 5.3?

Bug of Xsgi or xdm on IRIX 5.3?

Post by Shing Shong She » Thu, 29 Dec 1994 09:03:37



I don't know if anyone has encountered this or not but this has happened to
me several times on an Indigo 3000 running IRIX 5.3.  Once I logout from the
console, under some unknown conditions, the /var/X11/xdm/xdm-errors starts
to grow with the following messages:

        Warning: Select failed; error code 22
        Warning: Select failed; error code 22
        Warning: Select failed; error code 22
        Warning: Select failed; error code 22
        ...

Evetually it filled up my disk and trashed /etc/inittab; at this point you
cannot even shutdown the system -- had to restore the inittab from backup
each time.  Any clue what this warning is and how to prevent it from happening
again?

Thanks,
Shing Shong

 
 
 

Bug of Xsgi or xdm on IRIX 5.3?

Post by Jim Littlefie » Thu, 29 Dec 1994 22:18:12



: I don't know if anyone has encountered this or not but this has happened to
: me several times on an Indigo 3000 running IRIX 5.3.  Once I logout from the
: console, under some unknown conditions, the /var/X11/xdm/xdm-errors starts
: to grow with the following messages:

:       Warning: Select failed; error code 22

I'm glad to see we are not the only one with this problem. SGI has told us
that they are unable to duplicate this. We have had to "cleanup" about 4
machines each week which have been hit with this. I'm not pleased to hear
that 5.3 does not correct this.

"Cleanup" consists of shutting down xdm, removing /var/X11/xdm/xdm-errors and
restarting xdm.

--
Jim Littlefield             "I've got a bad feeling about this..." -- Han Solo


 
 
 

Bug of Xsgi or xdm on IRIX 5.3?

Post by Mark Kilga » Sun, 01 Jan 1995 08:58:51



|> : I don't know if anyone has encountered this or not but this has happened to
|> : me several times on an Indigo 3000 running IRIX 5.3.  Once I logout from the
|> : console, under some unknown conditions, the /var/X11/xdm/xdm-errors starts
|> : to grow with the following messages:
|>
|> :         Warning: Select failed; error code 22
|>
|> I'm glad to see we are not the only one with this problem. SGI has told us
|> that they are unable to duplicate this.

Please see my previous message about the problem.  SGI is aware of
the problem.  The problem is *fixed* now for IRIX 5.x binaries.  The
problem now only exists in old IRIX 4 binaries.

The problem is an indirect side-effect of setting the system date or
your workstation incorrectly.

|> We have had to "cleanup" about 4
|> machines each week which have been hit with this. I'm not pleased to hear
|> that 5.3 does not correct this.

The bug itself is compiled into old IRIX 4 binaries.  IRIX 5.0 through
IRIX 5.3 *did* fix the problem for new binaries.

- Mark

 
 
 

Bug of Xsgi or xdm on IRIX 5.3?

Post by Jim Littlefie » Fri, 06 Jan 1995 06:41:06


: Please see my previous message about the problem.  SGI is aware of
: the problem.  The problem is *fixed* now for IRIX 5.x binaries.  The
: problem now only exists in old IRIX 4 binaries.

: The problem is an indirect side-effect of setting the system date or
: your workstation incorrectly.

: |> We have had to "cleanup" about 4
: |> machines each week which have been hit with this. I'm not pleased to hear
: |> that 5.3 does not correct this.

: The bug itself is compiled into old IRIX 4 binaries.  IRIX 5.0 through
: IRIX 5.3 *did* fix the problem for new binaries.

Interesting, considering we are running IRIX 5.2 on all of our SGI's except
one (which has never had this problem).

--

Jim Littlefield             "I've got a bad feeling about this..." -- Han Solo

 
 
 

1. IRIX 5.3 color bug??

Hi

I am using Matlab R12 installed in our linux machine and plan
to set the display onto my local SGI IRIX5.3 computer. I found the figure
became totally dark and I cannot see any figure on my screen. It works
fine when I am using our Linux machine on console but has some problems
when I display the figures on my local machine.

However, when I use SGI IRIX 6.3 machine to display the Matlab, the
result is fine.
Can anybody tell me how to fix this problem in IRIX5.3 operation system? I
don't have this kind of color problem when I use other image software
except MATLAB.

Thanks a lot!

Yu

2. LOD info

3. 3d GRAPHICS BUGS ON INDY R4400XZ IRIX 5.3

4. Ray Tracing & The Ashikhmin-Shirley BRDF

5. BUG: Irix 5.3 overlay colour planes

6. Problem porting X application from IRIX 5.3 to IRIX 6.4

7. IrisGL problem: IRIX 5.3 --> IRIX 6.2

8. POV-RAY for Irix 5.3 - help

9. POVRAY for SGI Irix 5.3

10. Povray 3.01 compilation on SGI Irix 5.3

11. Povray3.0 modeller for Irix 5.3