Can't login with new user

Can't login with new user

Post by gen » Thu, 26 Jun 2003 14:00:44



I've been trying to create a new user for my system, but once created
I can't login as the new user.  I can ssh to the computer and login as
the new user that way, but if I try through the loginwindow, the
progress bar in the login window just spins and nothing happens.  I
sshd into the machine while this was happening to see if I could
figure out what was going on, but nothing looks out of the ordinary.
If I kill the Dock process of the user, the login window will go away,
but the cursor still spins (and Dock respawns, and a Finder process
starts).  I need to force restart or kill the loginwindow process
through ssh to get out.

This has happened with all the new users I've tried to create
recently, although I have created users in the past without this
problem.  Right now I have my main user account which works fine.  I
can't add any more without this problem occuring.

Holding down shift at startup doesn't help.  Deleting the few default
prefs files for the new user doesn't help.  Neither 'ps' nor 'lsof'
nor system.log tell me anything.  I am completely out of ideas!  The
system is up to date (10.2.6).

 
 
 

Can't login with new user

Post by sam gre » Mon, 30 Jun 2003 12:02:57




> Holding down shift at startup doesn't help.  Deleting the few default
> prefs files for the new user doesn't help.  Neither 'ps' nor 'lsof'
> nor system.log tell me anything.  I am completely out of ideas!  The
> system is up to date (10.2.6).

as a workaround,  you might try creating the new user using the terminal
window, to see if that does anything different. instructions at:

http://www.macosxhints.com/article.php?story=20030603190314390

I don't know too much about this, but is it possible that some netinfo
database is corrupted? that's something I would look into. using the
command line to create the user might be worth a shot. and/or check out
this page for info on what to do with a corrupt netinfo database:

http://diveintoosx.org/NetInfo.html