Eclipse 2.1.1 install on new system

Eclipse 2.1.1 install on new system

Post by Laura Effinger-De » Fri, 18 Jul 2003 23:29:01



Hello.  We are having trouble installing Eclipse on a brand-new FreeBSD
system  (Dell Precision 450 workstation).  The make from the port for
2.1.1 works fine but then any attempt to start Eclipse gives the same
error after a brief appearance of the splash screen (in fact an error
identical to the one that leafy mentioned in his email archived at
http://lists.freebsd.org/pipermail/freebsd-java/2003-July/000424.html ):

java.lang.UnsatisfiedLinkError:
/home/local/eclipse/plugins/org.eclipse.swt.gtk_2.1.1/os/freebsd/x86/libswt-pi-gtk-2135.so:
/usr/local/lib/libgthread-2.0.so.200: Undefined symbol
"pthread_attr_destroy"

We have tried installing with 1.3.1 and 1.4.1 as well as only 1.3.1 and
get this same error.  We also tried copying an older 2.1. port from
another computer and building that (using only 1.3.1), but the build fails
with:

file:/usr/ports/java/eclipse/work/plugins/org.eclipse.jdt.ui/build.xml:76:
Listener attempted to access System.err - infinite loop terminated

This error has also been mentioned on this list
(http://lists.freebsd.org/pipermail/freebsd-java/2003-July/000422.html).
We need Eclipse installed on our new computers so any help would be
greatly appreciated!  Thanks!

-Laura

_______________________________________________

http://lists.freebsd.org/mailman/listinfo/freebsd-java