/usr/ports/java/jdk14 -> LIBC_R TEST FAILED: libc_r update required

/usr/ports/java/jdk14 -> LIBC_R TEST FAILED: libc_r update required

Post by Philip M. Gollucc » Sat, 10 May 2003 15:05:54



p6m7g8# uname -a
FreeBSD p6m7g8.com 5.0-RELEASE-p7 FreeBSD 5.0-RELEASE-p7 #2: Mon May  5

p6m7g8# pwd
/usr/ports/java/jdk14
p6m7g8# make
mkdir -p /usr/ports/java/jdk14/work ;  rm -f /usr/ports/java/jdk14/work/testos
;  gcc -lc_r -o /usr/ports/java/jdk14/work/testos  
/usr/ports/java/jdk14/files/testos.c
if [ ! -f /usr/ports/java/jdk14/work/testos ] ;  then  /usr/bin/printf "\n You
must have a version of FreeBSD later than 4.7-STABLE\n February 2003 or
5-CURRENT February 2003 to compile and\n use JDK 1.4.1.\n\n" ;  exit 1 ;  fi
/usr/ports/java/jdk14/work/testos
LIBC_R TEST FAILED: libc_r update required
*** Error code 1

just from the uname, this shouldn't be the case.

cvsup to -CURRENT in libc_r ... same thing.

ran /usr/share/examples/FreeBSD_version

with output
Compilation release date: 500043
Execution environment release date: 500043

p6m7g8# gcc -v
Using built-in specs.
Configured with: FreeBSD/i386 system compiler
Thread model: posix
gcc version 3.2.1 [FreeBSD] 20021119 (release)

ls -l /usr/ports/distfiles/
[some output snipped]
-rw-------  1 philip  wheel  52251762 May  8 14:08 j2sdk-1_4_1-src-scsl.zip
-rw-------  1 philip  wheel  42250657 May  8 15:56
j2sdk-1_4_1_02-linux-i586.bin
-rw-------  1 philip  wheel    572923 May  8 13:57 bsd-jdk14-patches-3.tar.gz

--
END
------------------------------------------------------------------------------
Philip M. Gollucci
Consultant

URL   : http://p6m7g8.net/Resume/resume.shtml
Phone : 301.474.9598

eJournalPress
DBA / Software Engineer / System Administrator

URL   : http://www.ejournalpress.com
Phone : 301.530.6375

$Id: .signature,v 1.4 2003/05/02 23:46:37 philip Exp $

_______________________________________________

http://lists.freebsd.org/mailman/listinfo/freebsd-java

 
 
 

1. aio_nwait32 in /usr/lib/libc_r.a not defined

I need help please:

Below is the error I get when I try to start sqlplus or svrmgrl

"0509-036 Cannot load program sqlplus because of the following errors:
  0509-023 Symbol aio_nwait32 in /usr/lib/libc_r.a is not defined.
  0509-022 Cannot load library libc_r.a[aio.o].
  0509-026 System error: Cannot run a file that does not have a valid
format."

Thanks in advance for your help
RAY

2. Sorting Netscape Mail?

3. Yet another problem building /usr/ports/java/jdk14

4. configuring ZyXel ISDN TA Plus on Linux M/c

5. fail to build ports/java/jdk14 on 5-current

6. postfix and fetchmail (Linux-Mandrake)

7. ports/27748: Update port: java/orion (1.4.5_4 -> 1.4.5_5)

8. modules not found during bootup

9. java/50729: java/jdk14: broken java.net.NetworkInterface calls

10. libc_r.a compatibility problem

11. 8-17-00 4.1 libc_r uthread Build Bug

12. cvs commit: src/include pthread_np.h src/lib/libc_r/uthread Makefile.inc uthread_main_np.c