Problem upgrading 4 -> 5

Problem upgrading 4 -> 5

Post by Burt Gumme » Thu, 19 Jun 2003 14:30:00



I'm following the directions in src/updating and it simply says to do a
"make buildworld," however, I'm getting the following error:

cc -fpic -DPIC -O -pipe -mcpu=pentiumpro -DPTHREAD_KERNEL -I/usr/src/lib/libpthread/../libc/include -I/usr/src/lib/libpthread/thread  -I/usr/src/lib/libpthread/../../include -I/usr/src/lib/libpthread/arch/i386/include -I/usr/src/lib/libpthread/sys -I/usr/src/lib/libpthread/../../libexec/rtld-elf -fno-builtin -D_LOCK_DEBUG -D_PTHREADS_INVARIANTS -Wall  -c /usr/src/lib/libpthread/sys/lock.c -o lock.So
building shared library libkse.so.1
thr_libc.So: In function `sigaction':
thr_libc.So(.text+0x54): multiple definition of `_sigaction'
thr_sigaction.So(.text+0x0): first defined here
thr_libc.So: In function `sigprocmask':
thr_libc.So(.text+0x34): multiple definition of `_sigprocmask'
thr_sigprocmask.So(.text+0x0): first defined here
*** Error code 1

Stop in /usr/src/lib/libpthread.
*** Error code 1

I'm running 4.8 and my src tree is RELENG_5_1. The update process,
according to src/updating seems straight forward. Any hint as to what I'm
doing wrong?

 
 
 

Problem upgrading 4 -> 5

Post by Lowell Gilber » Fri, 20 Jun 2003 04:42:44


comp.unix.bsd.freebsd is not widely propagated, so you won't
necessarily get much help here (in comp.unix.bsd.freebsd).
See http://www.freebsd.org/support.html for better ideas...
[followups redirected accordingly]


> I'm following the directions in src/updating and it simply says to do a
> "make buildworld," however, I'm getting the following error:

> cc -fpic -DPIC -O -pipe -mcpu=pentiumpro -DPTHREAD_KERNEL -I/usr/src/lib/libpthread/../libc/include -I/usr/src/lib/libpthread/thread  -I/usr/src/lib/libpthread/../../include -I/usr/src/lib/libpthread/arch/i386/include -I/usr/src/lib/libpthread/sys -I/usr/src/lib/libpthread/../../libexec/rtld-elf -fno-builtin -D_LOCK_DEBUG -D_PTHREADS_INVARIANTS -Wall  -c /usr/src/lib/libpthread/sys/lock.c -o lock.So
> building shared library libkse.so.1
> thr_libc.So: In function `sigaction':
> thr_libc.So(.text+0x54): multiple definition of `_sigaction'
> thr_sigaction.So(.text+0x0): first defined here
> thr_libc.So: In function `sigprocmask':
> thr_libc.So(.text+0x34): multiple definition of `_sigprocmask'
> thr_sigprocmask.So(.text+0x0): first defined here
> *** Error code 1

> Stop in /usr/src/lib/libpthread.
> *** Error code 1

> I'm running 4.8 and my src tree is RELENG_5_1. The update process,
> according to src/updating seems straight forward. Any hint as to what I'm
> doing wrong?

The update process to the bleeding edge occasionally has some
hiccups.  That's why you're supposed to follow the -CURRENT
mailing list if you're going to run 5.x...

 
 
 

1. Problem upgrading 4 -> 5

But from what I understand, he is using 5.1 release, not current branch.
I heared something that includes from 4.x can conflict with 5.x, because of
that you could try to rename includes directory in case of compiling,
buildworld should use those in /usr/src. But I may be wrong.

--

UIN# 15827691, GG# 113344
SCSA, SCNA, LPIC, CCNA, MCP

2. Looking for a standalone IP package

3. Upgrade Problem: Redhat 5.2 -> 6.1 question --->

4. Malloc-ing out of specific memory

5. >>> System hangs after upgrading to kernel 2.0 <<<

6. How can I find out the Solaris version?

7. FTP problem: linux>>win/SGI slow win/SGI>>linux fast

8. Problem in rpc.ttdbserverd: Help!

9. Samba problem: WinXP <-> ADSL <-> Internet <-> Cable <-> Linux

10. Redhat 6 >> VFS problem >> Kernel panic??

11. <><><> MOUNTING EXTENDED PARTITION <><><>

12. Wanted: <><><> Unix Specialist <><><>

13. LILO help <><><><><><>