Add/Remove Programs not working...

Add/Remove Programs not working...

Post by Geo » Sun, 31 Mar 2002 05:53:35



Who can help me here...???

After a clean Windows 2000 Professional Install, I click
on add/remove programs from control panel and get the
following error:

"An Unexpected Error Occured - Class not registered -
Res://appwiz.cpl/default.hta - Line:225"  

I can click on OK and get past the error but then no
programs appear.  If I scroll down a bit, programs do
appear, some in duplicate - some in triplicate and even
more.  None of which can actually be uninstalled.

I did find a TID in Microsoft's knowledgebase that said to
run "regsvr32 appwiz.cpl" first and then look for a bunch
of registry hacks but none of that worked.  This has
happened to me on several W2K pro machines and is
beginning to be a real headache.  Has anyone had this
problem and found a fix that really works without having
to reinstall windows?  This is just a horrible bug in the
software that needs to be addressed.

Thanks Geo

 
 
 

Add/Remove Programs not working...

Post by Geo » Sun, 31 Mar 2002 05:53:40


Who can help me here...???

After a clean Windows 2000 Professional Install, I click
on add/remove programs from control panel and get the
following error:

"An Unexpected Error Occured - Class not registered -
Res://appwiz.cpl/default.hta - Line:225"  

I can click on OK and get past the error but then no
programs appear.  If I scroll down a bit, programs do
appear, some in duplicate - some in triplicate and even
more.  None of which can actually be uninstalled.

I did find a TID in Microsoft's knowledgebase that said to
run "regsvr32 appwiz.cpl" first and then look for a bunch
of registry hacks but none of that worked.  This has
happened to me on several W2K pro machines and is
beginning to be a real headache.  Has anyone had this
problem and found a fix that really works without having
to reinstall windows?  This is just a horrible bug in the
software that needs to be addressed.

Thanks Geo

 
 
 

Add/Remove Programs not working...

Post by Dave Patric » Sun, 31 Mar 2002 14:17:04


From the "Run" box try
regsvr32 %windir%\system32\appwiz.cpl

regsvr32 %windir%\system32\webvw.dll
to rebuild several *.htt files

If unsuccessful try
sfc /purgecache

sfc /scannow

Or try the regedits described in;
Add/Remove Programs Tool Displays Installed Programs Incorrectly
http://support.microsoft.com/directory/article.asp?ID=KB;EN-US;Q266668

If the problem persists, you'll likely need to perform an in-place upgrade.

How to Perform an In-Place Upgrade of Windows 2000
http://support.microsoft.com/support/kb/articles/Q292/1/75.ASP

--
Regards,

Dave Patrick ....Please no email replies - reply in newsgroup.
Microsoft MVP [Windows NT/ 2000]

 Who can help me here...??? After a clean Windows 2000 Professional Install, I click on add/remove
programs from control panel and get the following error: "An Unexpected Error Occured - Class not
registered - Res://appwiz.cpl/default.hta - Line:225"  I can click on OK and get past the error but
then no programs appear.  If I scroll down a bit, programs do appear, some in duplicate - some in
triplicate and even more.  None of which can actually be uninstalled. I did find a TID in
Microsoft's knowledgebase that said to  run "regsvr32 appwiz.cpl" first and then look for a bunch of
registry hacks but none of that worked.  This has happened to me on several W2K pro machines and is
beginning to be a real headache.  Has anyone had this problem and found a fix that really works
without having to reinstall windows?  This is just a horrible bug in the software that needs to be
addressed. Thanks Geo

 
 
 

1. Add/Remove Programs not working

Hi,

I recently set up a Windows 2000 AS Machine.  It seems that Add/Remove
Programs does not work.  When I click on Add/Remove Programs, I get an
hourglass pointer, then it disappears and nothing happens.  I have tried
copying a working copy of the Add/Remove Programs applet from another AS
machine to the "bad" one, but that didn't work?  Does anyone have any ideas
as to how to fix this?

Max DiOrio

2. HPFS Problems after install

3. COM port doesn't work (InterruptInitialize)

4. add/remove programs not working

5. Random Lockups

6. Is there a way to supress QHST entries by triggered pgms

7. Add/Remove Programs Not Working

8. Add/remove programs not working

9. Add/remove program not working

10. Add/Remove Programs not working

11. Add/Remove programs not working