Help!! with Cross Compiler setup for MIPS..

Help!! with Cross Compiler setup for MIPS..

Post by root » Wed, 07 Nov 2001 07:41:27



Hi,  all.

I have the following rpm files for setting up cross compiling
environment for my MIPS based devce.
I think these are all I need.
*********************************************************************************

binutils-mipsel-linux-2.8.1-1.i386.rpm
binutils-mipsel-linux-2.9.5-3.i386.rpm
egcs-c++-mipsel-linux-1.1.2-3.i386.rpm
egcs-g77-mipsel-linux-1.1.2-3.i386.rpm
egcs-libstdc++-mipsel-linux-2.9.0-2.i386.rpm
egcs-mipsel-linux-1.0.3a-2.i386.rpm
egcs-mipsel-linux-1.1.2-3.i386.rpm
egcs-objc-mipsel-linux-1.1.2-3.i386.rpm
**********************************************************************************

But while unpacking one of the packages,
egcs-mipsel-linux-1.0.3a-2.i386.rpm,   the following error occurred.


error: failed dependencies:
 egcs-mipsel-linux = 1.1.2 is needed by egcs-c++-mipsel-linux-1.1.2-3
 egcs-mipsel-linux = 1.1.2 is needed by egcs-g77-mipsel-linux-1.1.2-3
 egcs-mipsel-linux = 1.1.2 is needed by egcs-objc-mipsel-linux-1.1.2-3

Do I have to install any other packages other than ones I have?
Or.... these binary packages I have won't do for my machine? FYI, my
desktop is running Red Hat 6.1.

Any suggestions would be appreciated..

Thanks in advance..

Jong

 
 
 

Help!! with Cross Compiler setup for MIPS..

Post by Anders Larse » Wed, 07 Nov 2001 17:56:24



> I have the following rpm files for setting up cross compiling
> environment for my MIPS based devce.
> I think these are all I need.
> *********************************************************************************

> binutils-mipsel-linux-2.8.1-1.i386.rpm

                        ^^^^^^^
Don't install the above package!
It's an old (obsolete) version of the next one.

Quote:> binutils-mipsel-linux-2.9.5-3.i386.rpm

                        ^^^^^^^

Quote:> egcs-mipsel-linux-1.0.3a-2.i386.rpm

                    ^^^^^^^^
Again, don't install this one!

Quote:> egcs-mipsel-linux-1.1.2-3.i386.rpm

                    ^^^^^^^

> **********************************************************************************

> But while unpacking one of the packages,
> egcs-mipsel-linux-1.0.3a-2.i386.rpm,   the following error occurred.


> error: failed dependencies:
>  egcs-mipsel-linux = 1.1.2 is needed by egcs-c++-mipsel-linux-1.1.2-3
>  egcs-mipsel-linux = 1.1.2 is needed by egcs-g77-mipsel-linux-1.1.2-3
>  egcs-mipsel-linux = 1.1.2 is needed by egcs-objc-mipsel-linux-1.1.2-3

The error message is clear enough; you have to install
egcs-mipsel-linux-1.1.2-3.i386.rpm, not egcs-mipsel-linux-1.0.3a-2.i386.rpm
If you leave out the two obsolete packages, the rest should install
without problems.

HTH
cheers
  Anders