Ethernet Link goes down after the FS mount in MPC8540....

Ethernet Link goes down after the FS mount in MPC8540....

Post by siva » Sat, 11 Sep 2004 22:25:08



Hi All,

I have a peculiar problem. I am working on a MPC8540 processor with 3
ethernet interface. I am using the 2.4.20 Montavista Kernel with
Gianfar.c as the ethernet driver. When the kernel boots up it reads the
PHY id correctly and brings up the link also and i am also doing a DHCP
request in the kernel. It gets an IP address also without any trouble,
but as soon as i get the linux prompt..i am unable to ping external
network and moreover my ethernet link also goes down. So to debug a
bit, I manually brought down the interface and brought it up from the
prompt using Ifconfig. When it comes it auto-negotiates correctly for
the speed and says "link is up" but my ethernet link to the switch is
not there eventhough it claims Link is up. I am really puzzled ....what
might have gone between the interface bring up and FS mount.
Can anyone pls shed some  light on this.

Regards
sivam

 
 
 

1. Ethernet Link goes off after FS mount in MPC8540....

Hi All,

I have a peculiar problem. I am working on a MPC8540 processor with 3
ethernet interface. I am using the 2.4.20 Montavista Kernel with
Gianfar.c as the ethernet driver. When the kernel boots up it reads the
PHY id i.e a Marvel Chip correctly for TSEC1 and brings up the link
also and i am also doing a DHCP request in the kernel. It gets an IP
address also without any trouble, but as soon as i get the linux
prompt..i am unable to ping external
network and moreover my ethernet link also goes down. So to debug a
bit, I manually brought down the interface and brought it up from the
prompt using Ifconfig. When it comes it auto-negotiates correctly for
the speed and says "link is up" but my ethernet link to the switch is
not there eventhough it claims Link is up. I am really puzzled ....what
might have gone between the interface bring up and FS mount.
Can anyone pls shed some  light on this.

Regards
sivam

2. SGI Multilink & 1600sw + XFree86 4.1.0 + Radeon = 640x480?

3. 2.4.24: ethernet link going down?

4. Mounting ISO images: how many md devices can FreeBSD afford ?

5. Removing the route when Ethernet link goes down

6. Tux still alive at King County Journal!

7. Ethernet link goes down and comes back up

8. External Hardware Storage for UNIX (Sun- Solaris)

9. OSR5 + PPP + DNS = link won't go down

10. nfs link down, where do the files go?

11. Problem: ppp links goes down unexpected

12. Req. help: TCP/IP suddenly goes down on ethernet network

13. Help! ethernet keeps going down