ld.so continued

ld.so continued

Post by Kevin P. Ne » Mon, 20 May 1996 04:00:00




>Short Version:

>        Shared library minor revisions do not work on NetBSD 1.1.

>Long Version:

>Perhaps this is old news.   I'm just getting started with NetBSD.
>I looked at some of the older posts, but didn't have much luck finding info
>about this problem.

>If I have two shared libraries in
>        /usr/local/lib/libXaw.so.6.0
>        /usr/local/lib/libXaw.so.6.1

>Then "ldconfig /usr/local/lib" will load or cache  only
>the 6.1 version.  The "ldconfig -r" confirms this.

>When I execute a binary that was linked against the 6.0
>version, it will complain that the 6.0 file is not found.
>(The environment variable LD_LIBRARY_PATH is not set.)

Heh, this was fixed shortly after 1.1 came out. You have three choices:
1) Upgrade to -current
2) Grab just the fixed ld.so
3) Hang out for a couple of months and wait for the 1.2 NetBSD release.
   We are just now entering the release cycle for 1.2.

If you want to get on the mailing lists, that's cool. We have many people
who are on, and file bug reports and such. Course, we can always use
more help. Why not subscribe to the lists and help us out?

--


XCOMM Visit the House of RetroComputing at  /      Perm. Email: