lingjmp broken! Postgres fails!

lingjmp broken! Postgres fails!

Post by Arthur Hoffma » Thu, 25 Jan 1996 04:00:00



Hi
I have installed postgres on my NetBSD1.1-amiga. The compile went
quite well except for some minor problems.
The problem is when I want to initialise the postgres database I get
the following error message:

(the commands are done by the postgres user)

atze# initdb
WARN:fmgr_info: function 0: cache lookup failed

longjmp botch.
Illegal instruction - core dumped
initdb: could not create template database
initdb: cleaning up.

Then I do a gdb -c postgres.core and get:

GDB 4.11 (m68k-netbsd), Copyright 1993 Free Software Foundation, Inc.
Core was generated by `postgres'.
Program terminated with signal 4, Illegal instruction.
#0  0x21212b0 in ?? ()
(gdb)

What can I do to get around this problem? I really would like to be
able to run this data base.

Thank you all for your help.

Actually I have sent this message a while back already and Alistair
G. Crooks replied with the following:

Quote:> I've never seen this problem on the i386 port, which runs the
> regression tests for pg95 1.0pl14 fine.  So I tried to find where the
> 'longjmp botch' string was being printed.

He then said:

Quote:> take a look at /usr/src/lib/libc/gen/setjmperr.c, and
> /usr/src/lib/libc/arch/m68k/gen/_setjmp.S - the error is actually in
> longjmp, when it checks to make sure that the stack pointer is
> non-zero.
> Unfortunately for you, for some reason your stack pointer is zero, and
> so you bomb out.  From the comments in the first file, you could try
> to define your own version of longjmperror.  Or try to fix longjmp in
> the first place.

Well, as you probably all can guess: I wouldn't have a clue as to how
to fix this. I really need some help here, please.

--
Arthur.

__

========I need a Quantum LPS240 SCSI Hard disk: Dead or Alive=======
++++++++I need a SCSI Scanner - TWAIN compliant              +++++++